Download

Static Mesh doesn't update after reimport

Hello, i’m currently working on replacing the blockout props for the art ready ones. However, when i export my mesh to the same FBX that the blockout mesh is using, when i click on reimport, the mesh doesnt refresh. I’m currently deleting the blockout meshes and doing fresh import and works fine but i have to place them again on the map which is super tedious. Anyone know about this issue? I’m using 3ds max 2014.

Thanks a lot for your time!

What version of the engine are you experiencing this issue in?

The reimport button is broken, and I have already had a bug report filed from here: https://answers.unrealengine.com/questions/186758/reimport-fbx-model-doesnt-work.html

The work-around (for now) is to use the auto-import functionality by manually copying the assets into the content folder inside your project (through the Windows file explorer). It will automatically import into the engine.

Sorry, i should had ponted that out, i’m using the lasted one: 4.7.5. Thanks cyber, it works but it’s kind of annoying :confused: hope they will fix that soon.

Hmm. Im using the latest 4.7.6 and in the past hour I have reimported various models, over and over again. Worked perfectly everytime.
I remember faintly though that I had had a reimport issue with a pre-4.5 version…
Are you sure you store it to the same location? Sometimes Max takes me to a different folder when I hit export.

How are you reimporting?
A: Rightclick on the asset in the conten browser and select reimport
B: Select reimport asset from the static mesh editor menu

I think i forgot to download 4.7.6… that should fix it. I’m using method A to reimport the assets, i tried B today and worked but collision doesn’t update and stays with old collision setup, which is a big deal for the type of game we are working on! I’m sure i’m missing some checkboxs there in collision settings.

I’m having the same problem. When exporting from Blender and then reimport in UE4 the mesh isn’t updating.

Don’t know if it helps in all cases but…
I had this issue:

  1. Export a single mesh to FBX (3dsMax). Let say a car with no wheels
  2. Put the car in my level. Everything is ok
  3. I add now the four wheels (four instances of a same whell)
  4. Unreal refreshes (tooltip message) BUT! no wheels on the car!!
    The “almost-fix” is exporting is…
  5. Export to a new FBX (the car plus the wheels)
  6. Put in the level: the wheels are there!!
  7. Then every new export refresh correctly!! Maybe some changes in the instancies could break again later on, I didn’t try to stress this longer.