Download

Static mesh doesn't have complex collision, no matter what I do. WTF?

I’m doing a line trace with bTraceComplex=true (it’s for a bullet) so I want to hit complex collision, i.e. the visual mesh. I’ve got a static mesh with collision set to BlockAll and the trace channel I’m using is also set to Block in that collision profile. The trace goes right through the mesh with no collision result. When I turn on the complex collision display in the static mesh editor, nothing is shown. I don’t see any option to generate complex collision; only options for generating simple collision, which I do not want. The Collision Complexity setting in the static mesh editor is Project Default, but it doesn’t matter what I set it to; nothing works.

The only way I can get a collision on this mesh is to generate simple collision then set Collision Complexity to Use Simple As Complex. This gets a collision result but it looks wrong because… it’s simple collision.

I need to collide against the visual mesh, not some simple collision hull. For other meshes, this works just fine and doesn’t require any special setting. I don’t understand what the deal is here…? Why would a particular mesh just not have complex collision, at all? What gives?

Turns out there’s an Enable Collision checkbox up in the LOD sections, per-material, which was disabled on this asset because… reasons. Checking the box makes complex collision be A Thing again.