Download

Static Mesh disappears when animation begins. (From 'Import into Level')

Hi everyone. Hoping you can help me here.

For reasons I am building my level through chunks imported via the ‘import into level’ feature. I’ve had issues with this before and getting animations working. I’m basically just trying to create a lift that goes up and down when the first person player stands on it (later to be activated via key press). Previously I had tried making the animation in 3DSMax which worked fine in there, but imports the mesh as skeletal and it all goes downhill from there, so I’m trying to build the animation in-engine instead. I’m following a basic tutorial from youtube which would work fine to begin with. Every tutorial I watch imports meshes the normal way rather than using ‘import into level’. I’m wondering if this has some part to play in the fact that when I play the level and walk into the collision box, the lift mesh simply disappears. I’ve had a very similar issue before when getting doors to open at a key-press that have been imported the same way. They simply disappear, or teleport to a new position entirely.

I am wondering if the whole idea of ‘import into level’ placing meshes at exact co-ordinates is somehow conflicting with itself when trying to force static meshes to change location. Has anyone experienced similar before or might be able to offer a solution?

I’ve attached the BP I’m using to see if that prompts any suggestions.

Thanks