Static Mesh Disable Blueprints

I am having a problem importing my own files and assigning them to blueprints. I created a health pickup item and used a native unreal sphere as the static mesh. When I import any static mesh as .fbx or .obj it won’t work with my blueprints. I can change the static mesh of the health pick up to any other native unreal object, but any imported and reassigned static meshes will not maintain the functionality of the blueprint. I’m using C4D for my 3D modeling if that makes any difference.

That worked! I had auto-generate collision unchecked when I was importing. Checked the box and blueprints are working fine

The first thing I’d check is the collision. When importing meshes, the simplified collision is added by default but this settings can be overridden.

Open the mesh in the editor by double clicking it, and visualise it like so:

If the green wireframe is not showing, you can add Collision from a drop down menu at the very top.