Static Mesh and Level Sequences

I have an elevator that is triggered by a trigger box when touched, and the sequence that lowers the elevator only works if a static mesh cube is sitting on the platform. When the sequence starts, the cube doesn’t go down with the platform like it used to in UE 4.27. What can I do to make the cube go down as it is supposed to?

Would these be of any significance?

Here is what I’m talking about. The block in each clip has no BP behind it, but its Simulate Physics and Enable Gravity boxes are checked and its rotation axes are locked. The elevator at the start is programmed to move only when that cube is touching one of two box triggers on the upper floor.

Also, there is supposed to be a sphere that rolls out when a hatch is opened when the cube is pushed into another trigger space on the bottom floor. The sphere drops and rolls in the 4.27 version, but not the 5.0 version. Here is the level’s BP.

Level BP: Level Blueprint posted by anonymous | blueprintUE | PasteBin For Unreal Engine 4

Here is the link for a clip from the UE 4.27 version: Before.mp4 - Google Drive

And here is a clip from the UE 5.0 version: After.mp4 - Google Drive

Looks like gravity isn’t affecting the meshes. I was unable to reproduce the issue, though. Did you double-check whether “Simulate Physics” and “Enable Gravity” are checked? Do you perhaps have multiple installations of UE5 at the same time? (mainly UE5 AE / UE5.0)

I have Unreal Engines 4.27 and 5.0. After double-checking, I have confirmed that the block’s “Simulate Physics” and “Enable Gravity” are checked. I did try setting the Default Z Gravity on Project Settings, but that doesn’t seem to work, either.

Having 4.27 and 5.0 installed at the same time shouldn’t cause any issues. Sounds like everything is set up correctly, too. I’m honestly not sure what could cause this. You could perhaps spawn a default cube static mesh, activate “Simulate Physics” on it, and test whether that new mesh is simulated correctly. If it is, maybe dragging the meshes into the level again and activating “Simulate Physics” again might fix the issue.
If that doesn’t work… Then I’m afraid I would be out of ideas.

Nope, both cubes still float, unfortunately. It has to be because of the newer Chaos physics, and I’m out of ideas on how to change them accordingly. Even with both “Simulate Physics” and “Enable Gravity” checked, it doesn’t work.