Download

State machine blending between state changes?

I have a state machine in an animation blueprint that is handling a weapon firing. When the weapon fires, the slide blows back and returns to the rest position. This is modeled in the state machine as two states. The first being the idle or rest state and the second is the slide blowing back and then returning to start position. The problem is that it looks like the transition between the rest and slide moving states and then back to rest have some blending going on. This is causing some real issues since the slide movement occurs in just a few frames. I didn’t see any place to set/disable blending between states. Is there a way to do that?

1 Like

In the AnimGraph click on a transition between states, in the bottom right panel there should be BlendSettings section, set Duration to 0.

Ah, Thanks! I was looking at the state nodes instead of the transitions.