Startup movies skipping once loading has finished

Using Unreal 4.8.3 and I have 2 startup movies, both of them are encoded the right way, mp4 1280x720 25fps.

I added them in project settings in the editor and checked “Wait for Movies to Complete”, however they get skipped once the game has loaded, no matter what I do.

I have followed the instructions on the other threads about encoding the video in different framerates, resolutions, etc, and nothing works. How can I ensure my movies play all of the way through?

Hi Tarwine,

I don’t currently have 4.8 installed to test this, but I just tested this on 4.10.2 with the my UE4 Logo test asset, which I’ve linked below if you need to test.

This could have been a bug with 4.8, but I couldn’t find anything specific to ones not loading correctly or skipping past the video.

Test Asset:

Once you test this asset, let me know if it’s still occurring. If this asset works it’s likely the content you’ve created, or if it fails, then upgrading to a later engine version would be advisable fix the issue.

Thank you!


Thanks for the sample movie, I’ll give this a shot and see if it works. Worst case scenario we can upgrade versions, but I was trying to avoid that mid-production. Thanks for the help! I’ll reply with whatever solves the issue.

Understandably so. Let me know how it goes once you do try.


Hi Tim,

The sample video you gave me did not work in 4.8.3, and over the past month I’ve upgraded our project from 4.8.3 to 4.10.4 and I still have the issue.

No matter what video(s) we use, the main menu map loads as soon as it’s available, and skips the video. “Wait for Movies to Complete” is checked.

Hey Tarwine,

I just tested the video that Tim provided in a new blank project with the ‘Wait for Startup Movies to Complete’ option checked and had no issues with the video playback. I was not able to skip the video by pressing any inputs, as this is the expected result with the option checked.

Could you test and verify this is the case on your end in a new blank 4.10.4 blueprint project?

If you do manage to get the issue to reproduce again in a blank project, please provide me some simple repro steps in order get the issue to appear on my end so we can enter a bug report.

My educated guess is that since you have upgraded this project from 4.8.3, there could be conflicting references or instructions that were passed along between versions and now the setting is not being accounted for correctly.


Okay so I found the issue, I took a look at my DefaultGame.ini and found that this in my MoviePlayerSettings


In the project settings menu in the editor, it only shows that the two videos are present, and nothing about the additional two entries. I removed the two minus entries to leave


and it works now. Not sure how this happened, but for anyone else having this issue make sure your entries are correct in the ini file!

1 Like