Startup Movies Causes Game To Crash

After I setup a startup mp4 to play, it is the UE_moving_logo_v04_4k from Epic, my game crashes. This is a packaged Development build of the game. If I remove the startup movie, everything works just fine. The error I get is:

Assertion failed: IsInGameThread() || IsInSlateThread() || IsInAsyncLoadingThread() [File:Runtime\Slate\Public\Framework/Application/SlateApplication.h] [Line: 225]


Any thoughts or suggestions?

maybe you can try to add a delay(0) node before your play logic.
And you can have a test for playing same movie with button event and see if it works in runtime.

Sure, I can add a delay when my MainMenu loads, which is the first level. There is nothing on the level and it loads a widget and that is it. I am starting to strip pieces out of the MainMenu to see if I can narrow it down. I will try a delay and see if it helps! I am open for whatever at this point! LOL

Unfortunately that did not work. :frowning:

I needed to make changes to see if it was my code or something else. I created a fresh brand new “StartUp” level that loads a UMG menu that has text on it. That is my startup level. It has a blank GameMode. It has a PlayerController that creates the widget. I set those as my default GameMode and Map in the project settings. I added the movie as the startup movie (it is the epic unreal logo mp4). When I do a DEV build of the project, the movie plays and then same crash as listed. If I remove the startup movie, everything works, no issue.

There has to be something I am doing or something is not configured correctly.

Also also, I have used the 4k and HD version of the Epic logo and they both cause the same issue.

After some tinkering, I found my solution. I cannot say this solution would work for everyone, but it may at least help those who are having issues without good feedback from the logs.

I recently turned on the Pre-Load Screen Movie Player and the Custom Splash Preload Screen plugins. If those are on (installed) it causes the crash every time. Once I disabled those, all of my startup crashes go away. I hope this helps someone.

Thank you for your assistance @SimplestWay. Sometimes just talking it out and/or trying different solutions shocks an idea into the head!