Download

Startup movie help

Hello everyone I am struggling (more than I should be) trying to get a startup movie to work. In this example I have downloaded the UE4 Animation from here https://www.unrealengine.com/branding-guidelines-and-trademark-usage

I went in to project settings and added the movie to the Startup Movies - checked wait for movie to finish. Saved the project then hit play in the editor and it always goes straight to the game, no movie ever plays.
I then started researching, I now have this UE4 Intro video rendered 19 different ways, and I have tried all 19 different renders of this UE4 Intro (plus many other videos) and no matter how I render said video, they never work. I have tried in UE versions 4.9 , 4.10 and 4.11 preview build all with the same results.

Does anyone have a link to a video that they know works 100% in there project as a startup movie that I can download and test to see if it works for me. Or does anyone have a preset for Adobe Premier (or any other video rendering software) that will get my videos rendered and working properly for use within UE4?

I have literally been trying now for 3 weeks (in my spare time) to get a startup movie to function. I am now turning here for expert help.

Many thanks in advance.

Hi Dubstep_Alex,

Here is a sample video I use: Test Video

I didn’t convert the file, so I don’t think I’ll be any help initially with what settings were used to make it work and whatnot.

Some things to consider when you setup the movie file for the project.

  • the movie needs to be in your Project Folder > Content > Movies location. You’ll need to create this folder.
  • Use the option to “Wait for Movies to complete” so that they don’t end prematurely.

I was using this video quite a few times today in 4.10.2 so I know it’s at least working with that build. It should work with others as well, but I can’t speak to those since I’ve used it with them recently.

-Tim

Greetings Tim, thanks for the response very much appreciated.

I already have created the directory “Movies” inside the “Content” folder. (Also this folder is automatically created when adding a movie for the first time). I have double checked that the movie is in this folder, it is.
I have went in to “Project Settings” and went to “Movies” - deleted the video I am trying to get working and added your known working “Test Video” - saved/build the project then click “Play” in the editor - the game loads and no movie is shown before it, just goes straight to the game like all the other videos I have tried. So if you tell me this video works for you in your project, but it isn’t working for me in mine (or any other movie for that matter) then I can only assume there has to be some other option that needs checked somewhere, or maybe I need to add something to the level blueprint to call the startup movies to load at the beginning perhaps? Or have I discovered some type of real bug that should be addressed with a proper bug code so that developers of the engine can solve this for a future release?

When I am in the “Content Browser” of the engine and I go to the “Movies” folder and double click your “Test Video” the following screen that appears allows me to “Play” this “Test Video” and I can watch it perfectly, I can also watch my other videos just fine, they just don’t load/run/play on startup for some reason.

Here is an image showing the “Movies” settings.

769c79c45d3ed22d7289f2bbe5499dd7099624e4.jpeg

To rule out your project as being an issue, here is a sample project using the same video I linked above.

Test Project

This was created using 4.10.2 and when you launch you’ll need to make sure to launch in Standalone game to see the startup movie play.

For the record, to get a video to properly play at the start - it currently needs to be

Video to be

  • MP4 container
  • 720p (1280 x 720)
  • 25 FPS maximum

Audio to be MPEG AAC (mp4a) (48,000khz is fine)

That conversion can mostly be done using VLC. That’s what I used to convert from the UE4 LOGO intro given on the branding guidelines.

Is this only a start-up limitation or does it happen always when calling up movies?

That, I’m not sure.

Uhhmmm I hate to drag up a dead thread but it doesnt seem to see .mov files any more

Yeah it’s been a while (*spongebob narrator: “three years later”)

Anyways, my project wont load a movie OR a splash screen on startup (seemingly related). However, the editor splash does work… Any help?

Since this thread comes up pretty high on google, I’ll chime in. The settings above didn’t work for me in ver 4.14 for some reason but when I changed the video to:

  • MP4 container
  • 720p (1280 x 720)
  • 60 FPS

it worked no problem.

I used a raw AVI file recorded at 1280x720@60FPS (using sequencer) I converted to MP4 using VLC with default settings.

Here’s a easy tutorial on the subject for those who still have problems! https://www.youtube.com/watch?v=gGRHBZFOzEk

So I have a question. Can we use this video that you made to credit the engine in our games, Tim?

Bring the thread back to life. So I have the same issue where splash screen is good when opening editor , but does not play with packaged game. Some have said if game starts too quick , splash screen will not show. Is there a way around this? Like a " wait for splash screen to finish " setting? LOL , It doesn’t seem to make sense that you can put a splash screen but then it don’t show.

any ideas for this?

having same problem here.

Me too. Unreal 4.23 Wait for movies to complete makes no difference on Android. Also the music plays too fast/high.

It actually has to be a very specific format, we’ve found 1920x1088 (yes, 1088 pixels high) to be the resolution to work, with .mp4 @ 30fps, 48khz sampling rate AAC audio.

Good luck trying to use Adobe software to push out an .mp4 these days btw. This is a ridiculous bug that’s been in the engine for YEARS. I hope this helps someone trying to get the intro video working a few days before publishing their game, since it’s really hard to figure out and there’s literally one post on the Internet with the correct resolution.

Got the same problem here but for me the video did work earlier, even after packaging to android. Then to reduce the package I foolishly turned off a bunch of plugins (and might have changed some settings as well) and now the audio plays after the unreal logo and instead of video I get a white screen. The video is in the proper format as it worked earlier but now I don’t seem to remember what settings I changed that messed it up. (UE4.25).