Starting up Swarm Connection...(100%)

I’ve seen this listed… haven’t seen true fix. I seen reinstalled windows. Stopping Avast. Reinstall UE4.
Everything was fine 2 days ago and then boom… please help with a real fix because I cant afford for this issue to happen again. I left CryEngine and moved to UE4, spent 3 months converting asset and its feeling like a waste right now. Wiping Machine isn’t true fix.Please help!!
Windows 7 Ultimate
Malware Byte
I did a Dropbox install and that’s about it?!

Hi Fred -

First I would recommend that you take a look at the Swarm Troubleshooting Guide on our Wiki:

A new, community-hosted Unreal Engine Wiki - Announcements - Unreal Engine Forums

I would also make sure that you have a Lightmass Importance Volume in your level. If that does not work, try adding in the SM_Template_Map_Floor from teh Engine content to your level and rebuild lighting. This was a bug reported in 4.9 which caused Swarm to be unable to complete the Light Build and is corrected in 4.10.

Thank You

Eric Ketchum

Still having the issue?

I’m working on a project for a client and without being able to build lighting I’m at a stand still. I’ve review the lightmass setting and uninstall UE4 completely and reinstalled. opened the default scene, hit build and nothing!?

The information in the image, means that you either have another Swarm Agent running in the background on one of the computers in your Coordinator setup or on the Local Machine. If you don’t have any Swarm Agents open beyond the one instance, then you have a process running on your CPU that either is using the TCP Socket needed to run the Agent or blocking the connection.

Finally i fixed this issue , just verify the version . The swarm agent works again !

214961-qq截图20170928121147.png

This works for me !

The wiki is dead.

This did not work for me.

As a last resort you can disable the whole thing by going into:

World Settings: Lightmass: Force No Precomputed Lighting

And check it. No more precomputed lighting means no more attempts to attach to the swarm. No swarm, no cry. On the other hand, this will negatively impact your runtime framerate to some degree. How much? No idea… but it’ll be a hell of a lot better than “can’t build your game”.

I work on a relatively restricted network, on a game with nothing much going on with lighting, so this is an option for me. On the other hand, mucking about with my own registry (and FIPS in particular) isn’t an option. Your Mileage May Vary.

Has anyone tried setting up a legit Swarm controller and >=1 agents on other machines? This happened to me with a stand alone desktop with no swarm support.