Starter Content not added when creating a blank project in UE 4.10.0

In UE 4.10.0 when trying to create a blank blueprint project with Starter Content the resulting Content folder is empty, it works fine in UE 4.9.2.

Verifying the installation in the Games Launcher didn’t fix the problem.

Adding the Starter Content pack to the project after it is created works fine though.


I’m unable to verify this issue. Creating a blank blueprint project and adding starter content worked as expected for me.

  • Are you ensuring that when you are creating the project, you are selecting the With Starter Content option from the dropdown?
  • Also, has this issue occurred with multiple projects?

Yes, the Content folder in a new blank blueprint project is always empty in UE 4.10.0 no matter what I choose for the option With Starter Content, I tried several times with different projects. If I try to add the pack after the project was created it is added with no problem. This wasn’t an issue in UE 4.9.2

Tried all of the blueprint templates with default options i.e. Desktop/Console, Maximum Quality, With Starter Content and path /Users/MyUser/Documents/Unreal Projects all of them would have the StarterContent after a new project was created with the exception of the blank blueprint project. I’m using the version downloaded with Games Launcher on a Mac running OS X El Capitan. Unreal Engine version string is 4.10.0-2758231+++depot+UE4-Releases+4.10

  • What options are you using exactly to create the project? I.E. Desktop/Mobile, Maximum Quality, etc.
  • Also, have you changed the default file path for the project to be created in?
  • Does this only happen in blank blueprint projects, or does it happen in any template?
  • Are you using the launcher or source version of the engine?
  • Are you using a PC or Mac?

The problem appears to be solved after I created a Basic Code C++ project for the first time in UE 4.10.0, the new C++ project had the StarterContent folder, and then after that the blank blueprint project template was created with the StarterContent too.

Thank you for providing a workaround for this issue. At this time, we have been unable to reproduce it internally, but we will keep an eye on the issue to see if any new reports appear that could assist us in reproducing the problem.

At last! After trying several days a solution to this problem, it worked. I did not need create only was the “new C ++ project” option, I do not have Visual Studio installed, I returned to the “Blueprint” option> “Blank” and how magically “StarterContent” was full. Finally I am now free to design.

PS.: At first I did not scored all downloads of the install file, I decided to download only after “models and feature packs” and “Initial Content” even then had not been resolved. Well, this was my mistake!

The issue is still there as of UE 4.14 (at least on Mac). And the workaround still works :slight_smile:

Issue is still there for UE 4.15.1 on Mac. Workaround does NOT work unfortunately.

Same here 4.16.1 can’t get the empty project to show the starter content up. The viewport is fully black and the content browser says “Drop files here or right click to create content”…

Edit: Funny thing is that creating it without starting content shows up with the world set up and a plane with the player start icon.

Just had this issue in 4.19.2. the original work around solved the problem.