Start menu not disapearing

made a simple start menu but when I click start game the menu doesn’t go away and just stay’s there

Try Remove From Parent before you open you level. I believe when you switch levels, you lose the instance of the widget. Although you can still see it in the viewport, as soon as you switch, the remove node never fires because the new level is starting a new Game Mode, Game State, ** HUD **, etc. While this is a simple check to see if it works or not, you could also put a “Print String” after the Open Level node to see if it prints anything.

Hope this helps!

well that some what worked, tested it in editor mode and worked fine but when I package it to test it it does the same thing again

Right-click the main Content folder in the content browser and select “Fix Redirectors” then try again.

You may also want to delete your “Build” folder before packaging. Sometimes it won’t rewrite the files when building/packaging.

done that, still the same thing. I’m noticing it loads the HUD for about a second then goes back to the menu

I’m not quite sure then. All I do for mine is like I stated above and it works fine. Have you tried shutting down the editor, including the launcher and trying? Could be cached somewhere causing the issue. Could reset your PC just to ensure. If it’s working in the editor, it should work in the package build.

yeah I’ll try restarting everything, cause I’m having this issue with another open level blueprint of mine. Works in the editor but not when its packaged

Another suggestion would be to delete the Intermediate folder as well and let the Editor rebuild that when you start. I was having some issues with building, albeit different issue, a staff member suggested that I delete this folder and try again. While I can’t attest to it working or not (I just rebuilt my whole game from scratch) I am assuming it is safe to remove this folder and its files. Just in case, I would make a backup of it or just move it to a different location.

yeah I’m doing more testing and I think its something else, all my open level blueprints are not working. instead of opening the level that I’m telling it to load it simply just reloads the current level, including the menu. I’m just going to mark this as answered and start another thread since menu isn’t the problem