START game on particular monitor?

What is the command line arg or game setting that needs to be set for this?
The game only starts on monitor index ‘1’. Unity3D has the command arg “–adapter 2” option. What is this for UE4.12.5?

“WinX=0” doesn’t work.
“r.WinX” doesn’t work.

Tested in UE4-Command and as a launch arg in “–windowed” mode.

Necro-bump! bump bump bump bump bump bump bump bump bump

Might be old, but this proves i allready searched the forum and google for an answer to this and came up enpty.
Please some UE developer, weigh-in on this topic. it’s 4 years later, and many many game developers over on steam want and need this feature//ability.
This code repository.answer could be an easy way to point them all to a legitimate fix for many games still in need of this feature.

An example of this need is “Everspace” on steam, which is unable to set its resolution on Display#2 to any 4K resolution, due to being limited to whatever Display#1’s max resolution is.

This is a COMMON RECURRING UE ISSUE in gaming laptops with built in monitors less then 4K that have a display-port out to a 4K or higher “secondary” display. Such laptops often are forbidden from making the connected Display#2 thier primary monitor. and thus the UE engine cant detect nor display at Display#2’s native resolutions without windowed mode scaling and pixel doubling.

This is also a COMMON RECURRING UE ISSUE in desktop PC’s that have any lower resolution monitor as thier primary display, and a larger resolution capacity screen on thier secondary display.

Please respond with links and detailed instructions for a work-around if available, citing any policies or jira related outlooks on the topic here, as this old post is where google searches on this topic first deliver developers looking for an answer.

bump bump bump

I bumped into this post while trying to set it up few days ago. I eventually discovered the solution so here it is…

You have to set WinX command line parameter to the first pixel of your second monitor, which is in most cases the horizontal resolution of your first monitor. If your first monitor has the width of 1920px, you have to set WinX=1920 (the screen pixels are zero based).

If your displays are setup (in Windows display settings) so that the second monitor is on the left, you setup WinX to a negative value of the second monitor horizontal resolution. For example if the second monitor has the width of 1280px, you set WinX=-1280.

If the second display is placed above the first in Windows display setting, then you use a negative value for WinY parameter. Besides that, you can also use ResX, ResY and FULLSCREEN parameters.

This should all work with more than two monitors, and you can imagine it like this… all of your monitors make one big screen where the coordinate (0, 0) is the pixel in the top left corner of your primary monitor. The pixels of other monitors depend on how you postion them in the Windows display settings.

IMPORTANT NOTE: This won’t work if you have HTC Vive pluged in and running the game in VR, becuse then the application always gets displayed on the first monitor, regardless of how you setup WinX and WinY. If by any case (which is rare) you have to run two instances of the app on the same PC, one for VR and one for the second monitor, the solution is to make two app builds, one with Steam VR plugin enabled and one with the plugin disabled - in which case you might get some blueprint or compilation errors if you use Steam VR specific functions (using just motion controllers and their generic functions shouldn’t produce errors when Steam VR plugin is disabled). I haven’t tried t with other VR headsets, but I supose the behaviour is the same.

Hope it helps.