Start an VR Oculus App in fullscreen mode


How to start an Oculus VR app in full screen mode ?

I did :
UE5 from empty scene → create my game → package for android → install on oculus quest 2 → it start, it work

my app doesn’t start in fullscreen so I can’t use the in-game controller to move around and interact

thank you for your time and your answers

turn off ogl and activate vulkan

I tried, not working

Hi @imica-nice,

Try Project Settings → Package for Oculus Mobile devices → Add your HMD to the array

Also enabling ‘Project Settings → Start in VR’ might help.

Let us know!


Project Settings → Start in VR

this was already active

Try Project Settings → Package for Oculus Mobile devices → Add your HMD to the array

this was a good idea, now my app look like start in fullscreen

my app is completly black, no display…, infinite loading ?!

Hey, just checking if the problem could be solved or if anybody has an idea… I’m currently having the same issue… Would be very grateful für any help! :slight_smile:

Ok wow, it just worked for me :smiley: probably a combination of the suggestions from above and this tutorial: Discord Help, How To Load A New Level And Navigate In VR With UE4 - YouTube

Good luck!

I have the same issue with unreal engine 5.0.3 and oculus quest 2. When I transfer the apk file from unreal to oculus and try to open it, it opens as a window and no as a full screen. Also, I have to mention that I don’t have control of the pawn. I have already install Meta XR plugin and I have enable the Advanced Apk Packaging in Android. Does anyone know how to fix this?

you don’t need the meta plugin
only open xr is necessary
If you didn’t make it from the vr template you might be missing some controller inputs in your project config.
and of course, your nav won’t work if you don’t have a navmesh bounds