Standalone 'play' mode in Editor without 'Use single process'. Got some issues.

Hey there,

I’ve tried to use the following setup to pipeline my workflow with a Game/Server testing thing:


However, when I’m trying to launch, I get this error message from the Game instance. The Server loads up just fine:


It is the default map set for the Game instance. It doesn’t matter what map I have opened in the editor at the moment or if I try to specify another map on the command line. I still get this error about this default map:


I’ve cooked my content through ‘File->Cook content for <platform>’ and I have it in my <project>/Saved/Cooked folder indeed, though, I don’t quite understand where are the settings for this cooking process? I have my packaging settings set like that:


Looking at the log file it seems that the server is using some temporary copy of the map currently opened in the editor (its is Map_01, indeed). This is the command line passed to the Server instance:


And this one is being passed to the Client:


I’m pretty sure I’m just missing some ‘secret knowledge’ of how things work internally. Would be great if someone from Epic can explain this topic once and for all :slight_smile:

Right now I’m using staged builds via UnrealFrontend, but it’s a bit time consuming and the ability to iterate on stuff right out of the editor would be really nice to have.

This may be related: [4.8.1] Cannot connect client to editor server with commandline specifying IP - C++ - Epic Developer Community Forums

Yes, I ended up debugging this thing more thoroughly myself and fixed it in a simillar manner. Thank you nevertheless! :slight_smile: