Standalone/Packaged missing assets in path

Probably an easy flag for cooking or force-loading I overlooked somewhere, so here goes.

I have a widget system that relies on textures and knowing where what exists. On BeginPlay I use Asset Registry and ‘Get Assets by Path’ to create an array of all textures in a given path, so I can access it from the widgets.

All works well, but when playing in standalone mode or packaged, the array will only include textures that are initially used in the level, not all in the path. They seem to simply not exist. Set the directory containing the textures to always cook, but no dice. Any flag I need to set or way to force all textures/assets to be used in the game, even the ones that are initially unused in the world?

Hi!
I just faced exactly the same bug! :frowning:
Have you found any solution or workaround to that problem?

Sorry, never really figured it out.
Went with a slightly different approach where things at least work in built form for shipping.

Running standalone still doesn’t work, but figured that’s just a limitation of how standalone mode handles assets. So for testing I just play in editor.

Hi there!!
I am now going through this same issue… did you ever find a solution?

kind regards

Roberto

hello.

I’m also quite interested if anyone got any solution for this.

Edit: I had this issue with data assets combined with standalone, but fixed it by adding the base class in the asset manager settings.

Project Settings → Asset Manager → Add new element for “Primary Asset Types to Scan” and selecting you base class and its directory.

Not sure if this is a fix for OP.

1 Like

You are the best my Bro , This is the Right Solution