Standalone game crushes the client

I’ve ran into a problem that packaged game(development & shipment alike) doesn’t run. The game window opens and closes immediately. After some investigation I found out that running the game in standalone mode also crushes the opened client window. Also the game runs perfectly in editor mode.
I tried to alter some main blueprints like gamemode, HUD or default pawn - but nothing seem to work. Where could I possibly look to find what the source of the problem?
Thank you in advance for any reply!

Hello Taiwet,

I have a few questions for you that will help narrow down what issue it is that you are experiencing.

Quick questions:

  1. Can you reproduce this issue in a clean project?
  2. If so, could you provide a detailed set of steps to reproduce this issue on our end?
  3. Could you provide screen shots of any blueprints that may be involved with this issue?
  4. Are you by chance using/ have you enabled the experimental web browser widget for UMG?

Thank you for a quick answer!
Now to the matter in hand:

  1. I’ve tried to reproduce that, but everything seem to work just fine in a new project. I’m developing a turn-based board/card game and so I reproduced the start of the game, board, decks and drawing cards. The game packaged and played normally. I didn’t reproduce the specific cards and their behavior on the board. I’m still experimenting with variations.
  2. _ :frowning:
  3. I attached all of the screen shots, that could be of a matter.
  4. No I haven’t enabled no such thing. From things that I should mention(I think):
    I’m running windows 10 for a couple of days. Also I don’t think it really matters, cause I can package new projects just fine.(But I started that project on windows 8)
    My project was in a dropbox folder, so I could share it with a friend. At first I thought that it might be the case and copied the project to a different directory, but it didn’t work.
    The legend for the screenshots.
  5. The main browser and GameMode BP
  6. Player0(default pawn) and HUD_Main(default HUD) BPs
  7. MainMenu widget and MousePlayerController BPs
    4-5) Launching game in editor mode.
  8. Launching in standalone mode.

So after some tests I manage to locate the problem.
On game start - the player spawns a deck and runs a “card draw” function. When I delete the “card draw” function from the player - the game starts to run standalone. Here’s the screenshot of player “spawn deck and draw cards”. And also the card draw. It’s quite big and ugly:/ To make long story short - it checks the free space in player hand and spawns there a new card from the deck.

Hello Taiwet,

Could you try placing a delay before the card draw function to make sure that all the objects referenced by the card draw function are completely spawned into the project? The function may be getting a null value.

Hello Rudy!
Thank you for your attention!
I tried to use delay, but still no result. The interesting thing that card draw function runs only after you choose a player from the main menu. But the project doesn’t start if the function is there.
Could a lot of blueprints be an issue? Maybe I chose a wrong approach to the idea of a card game? A “card” is a blueprint which has all the needed interactions inside of it. Like drag&drop, spawn from hand, dealing and applying damage. And each different card is a child of the “card” blueprint. Now - there is about 20 cards. Maybe that’s too much BPs with a lot of interactions inside and the game can’t manage to load them all? Because when I delete all the BP’s with different cards - everything starts to run as intended. And game also packages and runs on other computers.
The “Deck” BP also has an array of classes “card”.
May this be the case? A lot of “heavy” blueprints?

Hello Taiwet,

Would it be possible for you to provide a copy of the project or a simplified version that still reproduces this issue on our end? This way I could take a closer look at the issue that you are receiving.

Hello Taiwet,

We have not heard back from you in a few days, so we are marking this post as Resolved for tracking purposes. If you are still experiencing the issue you reported, please respond to this message with additional information and we will offer further assistance.

Thank you.