Download

Stains/Black spots over walls

I know this has to be a common issue, but Ive been struggling since yesterday and I dont have a clue on how to fix it.
I work from 3dsmax and I didnt have this problem before.

This image is with the ceiling.

This is without the ceiling.

Ok, here is what I do :

  • Create a UV Lightmap on channel 2 (Its big enough, never got problems with those but who knows)
  • In UE while selecting walls/ceiling I give them Overriden Lightmap Res a value between 1024-2048 (enough for straight planes I think)
  • Build Lighting with Production quality.

I noticed if I remove the ceiling, most of the spots dissappear, but thats not a solution. My ceiling its a very simple plane without normal maps or similar.

So, I’m out of ideas. If you need any aditional screenshots, just ask me.
I’ll appreciate any kind of help or tips, thanks in advance

Looks like an ambient occlusion problem. Basically with the ceiling on, it looks like you’re only using diffuse bounces to light your scene. Bump up the bounces, or bump up the light power, or add some interior lights. Let me know how that works.

Thank you for your answer JOhnRose81,
lets see, I added one PointLight to the room and voila, all the noise went out even in Preview light build.

Anyway, where can I change those AO values? These are my Lightmass settings (I’ll assume its there, but if you can help me out for testing different settings…)

I don’t think Ambient Occlusion is the correct term here. The indirect lighting needs increased quality settings, while AO would not improve that situation where you had no light. Your Lightmass settings look pretty decent though; did you increase the bounces/quality/smoothness before or after solving this problem? Those should be good enough settings to have a completely dark room without anything splotchy(assuming no other lights).

If you still get splotchy problems when removing that point light, then I would look into improving your ceiling. Single-sided planes (or thin objects in general) don’t always play nicely with Lightmass. Either give it a foot or more of thickness or add a separate mesh that acts as a blocker. You can set the blocker object to be invisible completely or just hidden when playing the game, and set it to cast hidden shadows. I would expect that enclosed room to be completely black, so I suspect that the sunlight is leaking in through the roof, causing a few random photon hits here and there.

P.S. Be mindful of how huge your lightmaps are. It says you currently have 60 1k lightmaps and there isn’t even much content to your scene. You are going to run into unnecessary storage/memory problems if you keep piling those on. Most everyone will tell you that having even 1024 for the ceiling is overkill, let alone 2048.

You can separate the walls into multiple pieces so you can use more smaller lightmaps, it works pretty well since you can split along corners.

Also, make sure to avoid having walls or ceilings that go past corners, the area you don’t see still gets rendered into the lightmap and if it’s dark or bright it can bleed onto the rest of the mesh.

Give it a try with Static Lightning level : 0.7 , Num indirect bounces : 10 , Indirect light quality :10 , and indirect light smoothness above 0.75 ( max 0.9 )

and let us know if that worked. Also make sure you have some light that can reach that area.

Thank you for your support guys.

I had to change the AO and tweak a bit the Lightmass Settings. It didnt require any additional interior lights.

Also found too late about what you said darthviper107, next time I would model all the walls and floors like that.

@darthviper107 are you suggesting that the walls are separate objects or to break all the walls up and stuff them all on one lightmap?

I dont know if this helps but i had the same problem and i switched my lights to movable and it works its a cheap fix but you can get away with it

That splotches/stains problem above can be eliminated using lightmass portal in UE 4.11, and there’s no need to tweak the .ini file or using high indirect lighting bounce (usually value between 10-30 is enough).

Cheap in time, exact opposite in performance, changing the lights to dynamic is going to effect the scene tremendously

Detach inward facing - faces - select poly> detach. I would personally make 4 faces/separate objects from the walls alone and 1 for the roof as visible in your above image (just the first room) as an example. Keeping the outer faces which won’t be seen but assigning a small lightmap resolution to them. Floor is ok to just detach the inward facing - face as a whole and assign 2048 to it with the rest (non visible) at low lightmap res. I had similar problems starting out and i much prefer upping the indirect lighting as opposed to point lights.