Download

Staging DLC seems to be failing on Catalina and UE 4.23

Hey guys. I’m finding a new issue since I upgraded to Catalina. I’m not 100% sure Catalina is the cause, but it seems likely.

When I build my DLC from the project launcher I get the following error during staging:


Cleaning Stage Directory: /Volumes/Build/Poppy and Buddy/Art/IOS
Creating pak using streaming install manifests.
ERROR: System.ArgumentOutOfRangeException: Index was out of range. Must be non-negative and less than the size of the collection.

The problem occurs in CreatePaksUsingChunkManifests() inside Engine\Source\Programs\AutomationTool\Scripts\CopyBuildToStagingDirectory.Automation.cs

The array appears to be empty. The array is populated from a manifest file, with the filename provided by GetChunkPakManifestListFilename().

My first thought was that it’s Catalina’s enhanced security nagging, so I added every single Mac application and dylib to the exceptions list for accessing the entire disk inside System Preferences -> Security. This didn’t resolve it.

Curiously my base app builds fine, and the issue occurs no matter how I change my DLC configuration.

Also, debugging the engine on Mac is a huge pain. I hate it. As one possible way of debugging it I added some trace output to the script in question and told my DLC config to Rebuild UAT. This didn’t seem to do anything. Also, you can’t launch the debugger on Mac from the automation scripts like you can on Windows.

Does anyone have an idea about what I should try next?

Although I’d tried turning off chunk generation it still threw the error. I tried turning off pak AND chunk generation and that seemed to fix it. Not sure if this solves my problem yet though. I don’t mind loose files provided the Mobile Patching Utility knows about them and can download all of them.