Download

Stack sizes - first mod attempt

Okay,

I’m just starting out, have several ideas that I would like to do for mods.
So I’m starting out on something I believe would be easy.

Stack size mod.

I’ve follow through with what was in the main post in this thread.

I’ve got the PrimalGameData_BP, Level, and TestGameMode files copied over into a seperate folder with the mod name on the end.
(Thanks to Clipz for the youtube videos on this)

I’ve tried coping the PrimalItemResource_BlackPearl_Modname and PrimalItemResource_Wood_Modname and setting the stack sizes to like 2000 and weight to 0.1.
Compile and save.

Hit play in the editor, and admin spawn in stacks… and it isn’t changing the max stack size.

I’m missing something, probably very simple.
Can someone point at what I may have missed?

You never told the PrimalGameData file to use your items instead of the default ones, any changes you make to default files will be ignored. You need to remap your items ontop of the old ones to do that.

So go through all the resources in the game, and copy them to your mod, then go through them all and rename or add something to the end so you know it’s yours.
Then go through all the items in the game you copied and add a hackey new value to quantity 10,000 seems to be a favourite value for stack hackers.
Then go through the PrimalGameData file and remap every single item in the game you just copied.

Thanks Akukiyo, I did miss that step, okay back to work for me.

Okay did that, still not working… I’m only doing Wood as a “learn how to” on this.
Going to start over and re-watch the setting up again, maybe I missed something there. Granted there was only 4-5 of the drop downs to change and I did all of those.

Copy PrimalItemResource_Wood and call it Wood_StackHack.
change name to Wood StackHack click compile and save.

PrimalGameData_StackHack
-> remap item Wood -> Wood_StackHack

Set Primal Game Data Override to PrimalGameData_StackHack for TestMap.
Press play.
Click on screen.
Press tab.
giveitemnum 7 1 0 0

“received 1 x Wood StackHack”

sigh That is what i was missing… I was setting the LEVEL file, to reference the Primal, I missed the TestMap one.

Thank you.

If you want to cook and test in the release version that’s fine. But you’re trying to test in the editor right?

I was trying to do both. I got it working in the editor, but not release. I’ll work on it shortly doing the weekend house work for a bit then going to see some family. Will start fresh tonight. I think I just about have it.

Then I’m gonna watch a few more videos… One of my goals it to make some taller walls (kind like double high behemoth walls for water areas) So I can put water dinos in actually deep water.
Maybe design a Obsidian/Metal wall. 2 metal, 2 obsidian, charcoal, makes one obsidian ingot, then metal walls with the obsidian ingot instead. Just thoughts in my mind an a good amount of spare time to actually work on it.

Changed weight and stack size of stone, remapped on PGD, PGD overriden, but when I tried to craft campfire, it doesnt recognize the stone in my inventory.

Okay, crazy question.

Which COOK option do I use?
Been using Cook Mod, but the mod is uploaded, subscribed, when I load in single player, it doesn’t show up on the ESC screen and it isn’t working.

Am I using the correct cook? The links I’ve found just say Cook & Upload.

Your using the correct cook option. Are you selecting the mod before you start the game? …and since you have replaced the wood with your own custom wood now you’ll need to replace the resource requirements for everything that uses wood to build it, right?

But even if I do this for existing core items, would it work for another mod that has wood as resource requirements? I wouldnt be able to change it. Im kinda hijacking the thread but this is where Im stucked. Stacking works fine on single player, but cant craft items coz it doesnt recognize the stacked resource in my inventory.

I didn’t think so, but it looks like it. You would think that just changing the reference in PGD would do it.
I can admin spawn it, in SP, but when I chop wood, it gives the default.

No worries on that Simiyet, that will likely be my next stopping point.

I fixed my problem with not directly copying the BP but creating another BP based on original one (is this called subclassing?)

I wonder if I messed up the BP when I copied it… maybe that is part of the issue I’m having… gonna test that.

I may be way off base here and Iv never tested it out myself but would creating a “child” from the original base resource help at all when it comes to using it as a resource requirement for crafting items (as long as the tags don’t require exact resource item component)?

It’s mandatory to use a Child for a stack mod, or other mods will not use them.

If you want people to use your mod, they have to still be able to use others. Otherwise just put a note on your mod that this mod does not Stack. (StackHack no Stack)

My new issue is, I cant get charcoals to stack in the campfire inventory.

Edit: After watching “Creating a new resource” tutorial, it gave me an idea.

Okay, I fixed most of my issue. I was changing MASTER ITEM LIST… someone in the chat pointed it out, I needed to use the Remap Item.

NOW, if i could get stone to work correctly and still be used by slingshot. But it looks like slingshot is using exact link to stone only and won’t read the remap.