Stack overflow when clicking slate element

Error message:

First-chance exception at 0x00007FF9FBF43D30 (UE4Editor-Slate.dll) in UE4Editor.exe: 0xC00000FD: Stack overflow (parameters: 0x0000000000000001, 0x0000008E8E503420).
Unhandled exception at 0x00007FF9FBF43D30 (UE4Editor-Slate.dll) in UE4Editor.exe: 0xC00000FD: Stack overflow (parameters: 0x0000000000000001, 0x0000008E8E503420).

Call stack can be found here:

I tried to change current map’s default pawn class under “world settings / selected game mode”. After that it displayed a message that said “rebuilding class hierarchy” or something like that and crashed a split second later.

I was running a c++ based project that was converted from 4.7 to 4.8. Windows 8 platform.

Hey jonimake-

Could you provide more information about the crash? Where you changing the default pawn to a Blueprint or a code based class? Are you able to reproduce the crash in a new project? If so can you list the steps that caused the crash to occur? Let me know if there’s any other information that would help me reproduce this on my end.


I’ve just started seeing the same thing. We’re on version 4.8 (plus some changes from the future 4.9).

Just some more details:

  • Seems to occur when clicking on any “World Settings|Game Mode” dropdown.
  • The crash occurs before the dropdown menu actually appears
  • In our case, the existing items are all C++ (game mode/pawn/controller/etc.)
  • All our maps seem affected by this problem
  • If you save a blank map and restart the editor, it will also suffer the same overflow issue.
  • Also crashes if using the vanilla “GameMode” for the GameMode override (with it’s spectatorpawn, etc)
  • Workaround seems to be to start a new map, use any “World Settings|Game Mode” dropdown (doesn’t crash, YAY!) and then return to your original map (at which point everything works as normal).

The game mode class itself was blueprint based, but the project does have some C++ classes also, like my pawn class is C++.

Hey jonimake and Ruminant-

Can you both post the log files from the crash as well? Additionally are you able to reproduce this in a new project after creating a game mode blueprint and then changing the game mode and its settings through the dropdowns?

I should emphasize, we’re currently on a hybrid version of Unreal (it’s 4.8 + a few engine changes + a bit of bleeding edge), though we haven’t touched anything slate related. I only chimed in 'cos jonimake’s stack trace looked eerily similar.

Anyway, here’s the stack trace, and the project log.

The above was a fresh blank c++ project - no changes, just compiled and ran it from Visual Studio (in the debugger) . From the editor, I set the default project to be the last loaded. I then saved the initial empty map and restarted twice (why twice? because the editor didn’t load my map on the first restart - possibly because I had just created it, rather than having actually loaded it). Anyway, from here just touch one of the world setting dropdowns and feel the pain…

Hey jonimake-

After restarting the editor I experienced the same crash when trying to change GameMode settings. This has been bugged (UE-18136). As a workaround, if you open the world settings and click the drop down for Kill ZDamage Type first you can then click the drop down menus for the Game mode without the crash.