Download

Square leaves

Hi,

I imported some tree 3d models which won’t import correctly, so I have to manually adjust the leaf material.

This is how I have it right now:

I thought changing blend mode to masked and connecting the black and white texture sample with opacity mask would create the correct material and it looks correct:

correct_leaf_material

But in the game the texture is missing:

Am I missing anything?

Thank you in advance.

Normal != Opacity, use masked material

I am using masked material, I just showed the normal one because that’s how it was in the beginning.

That’s how it looks now:

But the texture in the game is missing like I showed in the screenshot.

Edit: Must have been a bug. I enabled nanite on the mesh just now and then deactivated it and suddenly the textures are there.

Nanite doesn’t work with transparency.
Read the documentation for 5.0 EA

1 Like

Thanks, but as I wrote above, it didnt work without Nanite activated. After I then activated and deactivated it, it worked.