Sprites not showing up after packaging

Hi folks,

I made a Blueprint 2D side scroller project using sprites.
The game runs fine, but when I package it and run, some sprites don’t show up.

I know this problem has already been reported(Black Screen on Paper2D - Asset Creation - Unreal Engine Forums), but it was not recent so I thought things might have evolved.

Nonetheless, I looked at the solutions in this thread :

  • First solution is to move to 4.3 (since it is a 4.2 problem).I am currently at 4.9, I don’t think it would solve my problem.

  • Second solution is to add a C++ script to the project. I did that, but when I compile, I get an error :

Info Compiling game modules for hot reload

Info at UnrealBuildTool.UnrealBuildTool.RunUBT(String[] Arguments)

Info at UnrealBuildTool.UnrealBuildTool.PatchActionHistoryForHotReloadAssembling(List`1 OnlyModules)

Info at System.String.LastIndexOf(Char value, Int32 startIndex, Int32 count)

Info parameter name : startIndex

Info ERROR: System.ArgumentOutOfRangeException: index is off limit.

The sprites still don’t show up.

Thanks in advance.

Hello Remy,

I’d like to help in this investigation first could you specify what device you are packaging for? What is your target hardware?

Also I noticed in the AnswerHub post you linked the user claimed all of their sprites had stopped rendering. Is your case this drastic or are there just a few sprites that are not rendering correctly?

Thank you for the info in advance,

Ed Burgess

Hi Ed, thanks a lot for taking the time to investigate this problem, it really is awesome to see that some people can help me.

I am packaging for Windows 64 bits.

If by target hardware you mean the computer I am testing the game with, it is a MSI GE72 Apache Pro, Intel core I7, NVIDIA Geforce 970m, 8GB RAM.
I have a SSD and a Hard disk, the project is on the hard disk, and the shipped game too.

My case is not that drastic. In one level, the sprites work, and in another level, they just don’t appear.

Note that a same sprite is working in one level and not showing in the other one.

I even replaced the sprites in the working level by the sprites that will not show up, and when put in this other level, they appear.

It is just that in this particular level, the sprites (all the sprites) never show up.

Thanks again for your time and I totally trust your ability to solve this problem.

Hi Remy,

I’m assisting Ed with your post… I see you are packaging for Windows 64. Can you provide your entire Output Log? -But before trying to output again, please
right click on the Content folder in the Content Browser and select Fix Up redirectors in folder. Also run a map check for each individual map/level in your game.

Thanks,

Steve H.

Hi Steve, thak you for investing some time on this problem.

I Fixed up the redirectors in folders, I map checked all my levels (No errors).

I packaged for Windows 64, the problem is still there. The sprites of a particular level are not displayed (although collisions work, this means the capsule for collision is really here, just the sprite is not here).
Here is my output log of the packaging

Here are some additional things to try:

In your output log it shows… Warning: Asset ‘…/…/…/Engine/Plugins/Runtime/LeapMotionController/Content/LM_PassthroughMaterial.uasset’ has been saved with empty engine version. The asset will be loaded but may be incompatible. Search the Content Browser for LM_PassthroughMaterial and rename it.

Save your project and close. Delete the Intermediate and Saved folders from the Project folder, reopen the project, and try to package. If issue persists, close project and delete the Config folder as well. However, deleting the Config folder will require re-entering Project and Editor Settings like “Inputs.”

In your packaging settings, include debug files, and post those files here for evaluation. If you are generating chunks, try to package as one pak file instead and see if this resolves the issue. If not, can you provide your project for evaluation? If you are able to, you can send me a link to your zipped project in a private message on our Forums.

I renamed LM_PassthroughMaterial , I deleted the Saved,Intermediate and Config folders.

It worked !

Thanks a lot Steve !