Split screen cameras display black screens [4.7 Preview 6]

As far as I know, this wasn’t an issue in preview 5.

I discovered problem inside my game, but I created a new third person template game and had same problem. Camera works fine with just one player, but as soon as you add a second player (I did this via blueprint), both cameras are black. Setting it up same way in 4.6 resulted in no issues.

Hi Melisande,

I haven’t been able to reproduce this in a 4.6.1 project converted to 4.7 Preview 6, nor with a new project in Preview 6. Can you post an image of your BP that creates new player (and anything else you think might be relevant)? Thanks!

I’ve attached how I created it in both 4.7 preview 6 and in 4.6.1 and results when I play in editor.

Hm, I’m not getting that at all. Are there any other changes in editor or to project before this starts happening? Does this happen with a Third Person BP template project right out of box (with just that change to Level Blueprint)? If so, would you mind uploading test project somewhere so I can take a look?

I’m not making any other changes - just opening up template project and adding those 2 nodes and that’s it. Followed same procedure with both. I’ll get that uploaded and give you a link ASAP.

I’ve uploaded it here:

It’s saying that map was made in an engine version newer than this. Are you using 4.7 Preview 6 binary from Launcher, or did you get something from GitHub?

From launcher

Iiiiinteresting. Try doing a Verify of your Preview 6 install in Launcher and see if same problem occurs with a new project.

Done and still getting same issue. However, I did notice on opening level blueprint to add in create player node that I got errors: Blueprint “ThirdPersonExampleMap” was updated to fix issues detected on load. Please resave.
Blueprint requires updating. Please resave.
Which maybe has something to do with it?

Also, I had a couple of friends try this out as well. They’re not getting black screens but they are getting Player 0 displaying weirdly. One of them also said that once they tried possessing a pawn they got a black screen following that. I’m attaching two screenshots they sent me of their own Third Person template games.

I tried to reproduce this and found same sort of issue.

I was able to get a build of preview 5 and preview 6 for comparison. Both of these use third person template with a duplicated player controller and same additional code in level print.

I also discovered that if you change shadow quality down to Low, screens go completely black.

Hi all,

Can you verify whether making all Engine Scalability Settings as Epic fixes this issue?

Additionally, see if this happens in 4.7. There is a separate issue with scalability for some users, and I’m wondering if this is related.

Just want to say that all these issues no longer show up for us (I’m working on same game with Gamepopper) as of 4.7 Preview 8. black screens I was getting was due to shadows being set to low (I forgot I had changed that value previously).

Hi all,

We believe that this has been fixed with some other changes as of Preview 8. If you are still experiencing this issue in 4.7 Preview 8 or later, please comment here and we’ll continue investigating. In meantime, you can likely fix issue by adjusting Engine Scalability Settings to Epic. Thanks!


I was using 4.7 and had same issue. However I notice that one camera had under follow camera properties ‘constrain aspect’ activated, while second didn’t. This occured into a black screen. Unticking or constraining both aspect ratios of cameras solved it for me.

I’m having this issue in 4.10.4.

I’ve figured out that it’s happening when display window in-engine isn’t in a 16:9 ratio.

Is there a way to lock it to that ratio??

Hey AntonJG,

I haven’t been able to reproduce this issue on my end using 4.12.5. Could you please try in that version, and if you are able to reproduce issue, please provide repro steps so that we can see it on our end?

Thank you

Hi, After doing Battery Collector tutorial i just added this line on beginplay at gamemode class

GEngine->GameViewport->CreatePlayer(1, here, false);

i create a two pawns with editor one for player 0 another for player 1. On pawn settings i set autoposess player1. When i posess second player (player 1) bottom screen becomes black.



Due to age of this thread, could you please create a new post in Bug Reports section for this issue? Provide as much information as possible, including repro steps and any related code.