Splinemesh Tunnel Collision

Made a blueprint which creates tunnels. The collision is made up of simple box shaped meshes 4 sections each for walls on each side, floor and ceiling (16 hulls in all). The collision bends along with the tunnel as expected.

Collision node is present in the blueprint and is set to collide.

Collision works fine for the character but the third person camera goes right through it.

Is there a setting somewhere that I am missing?

Figured this out: needed to add a “Set Collision Response to All Channels” node in the blueprint.

You must edit you geometry in Unreal Engine, in the section of:
collision>collision complexity
chose:
“block all”
“use complex collision as a simple”

I just made a tutorial about that, is in spañish but you can see the video to understand Colisión en Túnel - Tutorial Unreal Engine - YouTube

333292-2021-03-22-19-33-12-tunel-unreal-editor.jpg