Download

Spline Question

I’ve read the doc and created a spline to place a road in my project. Having done so repeatedly to get it perfect I find that I cannot save. If I switch from the edit splines tool the entire length of road disappears. This happens even after I save the project or build the lighting. I’ve quickly scoured the web and have looked at every setting I can in UE that may offer some way to save this spline, Am I missing something?

-which engine version do you use?
-could you post a pic of your spline track so that we can see how it looks like?
-what happens when you go to the “edit splines” tab again -> can you still see something at the place where the road was? :slight_smile:

UE 4.8.3
The spline looks great, its just a dirt road with vehicle tracks on it that extends maybe 100-150 yards.

When I return to “edit splines” tab again the spline is back in place, I can add to it or delete from it. It just seems odd that I’m unable to find a way to save it.

88fd26badf704d05310393b622b798a0b2991928.jpeg

After hitting Play.
b3acc06b38f775ba056933d10b3c78141b92401f.jpeg

Anyone? This issue is persistent, I’ve recreated the road several times with the same result.

I followed this tutorial : https://docs.unrealengine.com/latest/INT/Engine/Landscape/Editing/Splines/index.html

Really strange -> would it be possible that you can share your project so that we can test some stuff? :slight_smile:

I suppose, is there an email, ftp site, I can send it to? I’d rather not link it in here.

Incidentally, I attempted to add the Roads and Paths pack to another project, something unimportant to me, and it behaves the same exact way. The R&P pack says it 4.8 compatible, do you think it could be the issue?

When it’s from a marketplace package, then dont send it to anyone (I think that’s now allowed) -> what happens when you use your own assets for the spline? + normally when they say it’s compatible with 4.8, it will work

I’ll attempt that now and post the result. I wonder if there is an update to the package since it was sold on the condition that was compatible.

I attempted to spline using ground_Dirt from Gametextures Material pack and then Cobblestone from the Starter Content. Each time when I left the Spline editor, either moving to another tool or entering the screen using Play, the spline disappeared. I have to think its something I’m doing but I did follow the tutorial enough times to be sure I didn’t miss anything. I ran a verify on my EU and no issues were presented. I’m at a loss to understand this.

This is probably the most aggravating experience I’ve had with this engine to date. I’ve contacted the vendor of the roads and paths pack. They tell me that there have been issues reported but its inconclusive if the issue is with 8.4.3 or their product. They offered to look at my file to examine what may be going wrong. I agreed, but concerns about sending off something I worked so long on to essentially strangers got the better of me. I tool another route.

First I did a manual backup of my projects, then I ensured carbonite had backed up the projects. Second, I uninstalled UE, deleting the Unreal Projects folder, wiping the vault from my hard drive. Keeping only my project file I placed a few of my packs, the needed ones, back into the project. In my 4 story construct I lost two story’s. Fine, I can rebuild it easily enough.

I maneuver outside, open the spline editor and create a short road using a bricks, it looks fine. The moment I move from the editor its gone.

Now, the roads and paths wasn’t loaded so I can’t blame the pack anymore. I have to conclude this is a bug.

Next step: Literally rebuild my entire project from the ground up using NOTHING whatever from the previous revision. A virgin program platform should remove any concerns about any package or plugin that could be causing this issue.

Needles to say this is more than a little frustrating - I did good work on those top two floors.

Lastly, is there some particular method to saving the splines? Did I miss something in the tutorial about how to properly apply them? if not, I hope this is addressed in the next . update. I really would like to add some roads and NOT have to rebuild this structure a third time.

Actually in my case (I also use 4.8.3) it works -> what happens when you try to create a spline with meshes instead of just materials?

The pic’s above did use mesh’s from the Road and Path patch. The result with materials or meshes, marketplace bought or stock, is the same. This is why I initially thought it was something I was doing. After a complete reinstall though I seriously have to wonder about the engine.