Spline Points Resets When I Change The Software

I have a blueprint named TrackGenerator that works on splines. I wanted to develop this BP class a little bit so I created TrackGeneratorNew and I added new specifications that I wanna add. Everything looked okay.

Then, I tried to replace existing splines softwares from TrackGenerator to TrackGeneratorNew. But, all of my splines kinda removed. BP data was okay; like track width, track bank, mesh data etc. But all of them turned into very small splines with only 2 points.

I tried replacing the old software with the new one without deleting the old one(by replacement), but I was still able to reproduce the bug.

Hi SalihBalkan,

When you say that you are changing the blueprint splines ‘software’, do you mean that you are creating a new blueprint based off of the old one?

If a spline was created by pulling and adding points in the editor viewport, that data is not saved. It is expected behavior for a blueprint that is based off of it to lose the spline data. We do have some changes in the works that may change this behavior down the road.

You can however create a spline blueprint that would work this way. You would need to completely add the spline points and set them in the Construction Script of the blueprint.

Thanks for your advice to recover the spline points. However, it looks like ‘Add Spline Point’ function doesn’t work at all, so that I wasn’t able to reconstruct the spline in the construction script. How can I fix this?

I just tested this and it is working properly for me. Give something like this a try:

If you still can’t get them to work, post some screenshots or a small test project showing your setup.

I don’t know why the function didn’t create points. However, I was able to move my splines with a workaround. I created an empty project, I moved my splines to that project. Then, I changed and saved the blueprint in the real project. Finally, I just copied and pasted the splines from the new project to the real project. And now it looks okay.