Download

Sphere polycount from content browser is too low

I have been having a problem importing a high-poly sphere I created in Blender to Unreal Engine. I can import the fbx mesh but I can’t texture an Earth map to it for some reason. So for my quick fix I want to drag the static sphere mesh from the content browser in Unreal Engine and texture-map that. It maps just fine, but the mesh creates a blocky sphere when I move closer to it.

How do I raise the polycount for the Unreal Engine sphere?

Thanks.

When you have the untextured mesh inside UE4, import your texture. Create material, apply texture to material. Then apply material to your naked mesh.
When the ball is uvunwrapped, then the texture will fit.
Tip create second uvlayer, in edit mode with that uvslot active and all faces selected, hit u “make lightmap/pack” set distance to 0.03.
While import uncheck “generate lightmap” in ue.

Thank you for that tip on importing the mesh, I will give that a try. But is there no way to set the polycount on the for the sphere that Unreal Engine already provides in the content browser?

Nope, because its is a static mesh “as is”.

Extra Tip: Create the 2nd UV channel also in your 3D app. It gives you more control over the results than the UE4 built-in unwrapper.