Sphere collision to ignore projectiles

Hi, I followed one of your tutorials: - YouTube.

The “ignore projectiles” in the collision tab, is not available in 4.8.1. (Tested it in 4.7.6 and it was available).

How do i make the projectiles go through the collision sphere in 4.8? Thanks in advance.

Check what type of collision your projectile is, then , in the sphere’s collision settings, set it to custom and overlap the projectiles collision type?

I’m on the same tutorial and ran into the same problem. after some search, here’s how i solve it:

  1. Go to project setting, browse to collision.
  2. Click new object channel, create a Object channel. Name it Projectile, default response block.
  3. Expand the preset at the bottom: add new preset, name it Projectile as well, Collision enabled - No physical collision. Object type choose Projectile which is the one you just created in preious step.
  4. Accept and close project setting.
  5. Go to blueprints, open FirstPersonProjectiles blueprints
  6. Select Collision Component from the Component list.
  7. In the details pane, scroll down to Collision. under collision presets, select Projectile.
  8. Compile and save
  9. Go back to CanPickUp Blueprint, now you should be able to set the trigger’s collision to ignore the projectile ball.

Very new to the engine, probably there are smarter way to do this, would like to learn.

Cheers

Yes, your solution is good, just precise at the step 9:

Go back to CanPickUp Blueprint, now you should be able to set the trigger’s collision to ignore the projectile ball.

That we have to select Custom on the Preset Collision and check ignore on the choice for our Preset Created.

Sorry for the late response. Thanks for the solution! I also created a new trigger preset to ignore projectiles, making it easier for future stuff. Just a tip that might be helpful for anyone else reading this.