Download

Speedtree Textures Stripped when Packing

When I pack my project to turn on my testing machine My speed trees all load in gray without textures.

I turned off using .pak file so i could see the directory and the textures and materials are there they are just not getting loaded from the packed version.

Check if all your content is saved in the content folder of your project :slight_smile:

yeah as I said all if the .uasset files and textures are there The textures are in the packed project under “content>textures”

Everything looks fine in the editor but in a packed runtime my trees have no textures. It there some social way that they have to be? like do the the tree models “the .uasset” files and the “texture” files have to be in the same folder?

Basically I Mainly use Maya as my Content creation platform and I use the new built in Unreal exporter. And it creates a import colder under my unreal project. So I saved my trees out of speed tree to that same folder. then just like any other asset I take it and drag it into the content browser.

Then I moved the textures in the textures folder of the content browser. this has worked flawlessly for any kinda asset. FBX, Substance, anything.

So it seems they need to bee in same folder for some reason. I deleted them all from seen and re-imported and left everything in same folder and it worked fine. So this sounds like a bug or at least something that should be documented. I mean if it broke it in the editor as well then you could say that maybe a speed-tree issue but it sound like be an issue with the UE4 implementation or at a minimum an issue with the packing of speed-tree assets. My guess is that the path the texture is getting packed incorrectly.

Filed as bug in answer hub

https://answers.unrealengine.com/questions/118560/bug-in-speedtree-packing.html