Download

Speak My Words -> Android's Text To Speech For UE4

Speak My Words

The Speak My Words plugin lets you integrate out-of-the-box Text To Speech API for Android into your Unreal Engine 4project.

  • Current version: 1.0
  • Binaries compiled for: Unreal Engine 4.18.1
  • Required Unreal Engine 4.18 or above.

**Get it on Github

https://github.com/DrawnzerGames/SpeakMyWords**

Features

  • This smart plugin will speak whatever you want to speak.
  • Set the speech rate for whatever you want to speak.
  • Set the pitch for whatever you want to speak.
  • Works with dev & shipping builds.
  • Out-of-the-box Android.
  • Additional SDK included.
  • Works with Blueprint-only & source code projects.
  • Works with Launcher & GitHub UE4 versions.

Setup

Copy this folder to the Plugins folder located in the main path of your project. Enable Speak My Words in Edit -> Plugins -> Augmented Reality -> Speak My Words.

Easy To Use Blueprint Functions

  • First Initialize the Speak My Words, recommended time to initialize is at the start of your level.

  • Then use these simple Blueprint functions from anywhere to speak, set pitch and speech rate at any moment in your game.

This looks fantastic and I have a good use for it but I can’t get it to load. You say “Binaries compiled for: Unreal Engine 4.18.1” yet the binaries seem to be missing as far as I can tell (“Binaries for the “SpeakMyWords” plugin are missing or incompatible with the current engine version.”).

Am I misunderstanding something? I work entirely with blueprints and have never used Visual Studio so I have no idea how to compile it myself.

I assume, you don’t have Visual Studio installed at all, and you are using launcher version of UE4, in that case it will fail.
I didn’t upload the binaries to the repository assuming that everyone who uses the UE4 will definitely have Visual Studio installed.
So no worries, I will push the binaries today evening.

Thank you! I have already figured it out and successfully implemented it into my app but forgot to reply. It’s working great!

What are your license requirements? I planned to use it in my completely free app (no ads) and so far mentioned you and your plugin in the credits.

Its free under Apache License 2.0,you can use it for free and commercial purpose as well, please let me know about your game, I will definitely play.
And thanks for using my plugin.

Here’s my app that uses your fantastic plugin!

Pretty cool! Any plans to add support for Windows ?

Thanks mate, this game is really awesome to play.
I will recommend it to friends as well.
Please keep following my github page, I m going to launch some more cool plugins as well.

Hey this is a great Plugin, however, everytime i launch the game on android the game crashes at “Init Speak Mywords” - node.

I build it using 4.19.2. There are no Errors in the output log, the module is compiled. I’ll do some more testing and hopefully i can get this to work :slight_smile:

is possible make speeach to text???

Yes this is possible.

Also wondering if this works on windows or any other platform accept android? taking my first baby-steps with UE and would like this to work very much!

Got it installed and got a blueprint going but nothing (no sound) happens on my windows machine :confused:

I know there are other tts plugins out there but this is the only one with a pitch input which seems awesome!

Best regards!

Would also love to see this for windows

Found the repo here: GitHub - piandpower/SpeakMyWords: Text to Speech Plugin for Unreal Engine 4 for Android using Google's Text To Speech API … it moved I guess?

I know this is an old plugin and probably has very little support (as i can’t find much on it anywhere!) but I installed/compiled it all up and my game runs on my android headset with it - but I can’t seem to get it to actually make any sound!

The init function works and runs (it knows when it’s Android and not) however it doesn’t appear to think it’s initialised using the IsSpeakingInitialized() function.

If anyone has got this working I’d love a bit of guidance! Thanks!

Edit: Correction it is initialised, but it just doesn’t make any sound!

Can anyone tell me how to fix it? I tried to build the plugin after placing it in project folder. I have Unreal Engine 4.25

II tried placing it in the engine plugins folder and i got this. Where do I need to build it in that case?
Screenshot 2021-03-08 142119.png

@Sarethh
I’ve gotten it to compile - you need to have the full engine code available as with any other plugin to get it to compile. Just add “Modules/” at the front of the ModuleManager.h include.

Just make sure the system you’re using allows you permissions to access it (which the Quest/Quest 2 doesn’t appear to have).

@Boruki Thanks a lot it works now.

With some research it would appear that this is not accessible on the Oculus Quest 1/2, which is why it doesn’t make any noise.

Please update the link to the GIT repository