Spawning Actor With "Spawn Actor From Class" Makes The Actor (Character) Stuck In The Air

I don’t know if this is a bug but when I spawn my character into the level it gets stuck forever in the air.
Well… It’s already all I needed to say.

Voyder Rozann

1 Like

… initially, I’d just check a couple of things:

  • the spawn transform: where are you making it spawn?
  • the actor’s physics setup: if you’d like it to fall to the ground, make sure it’s set up so that gravity is acting on it
  • you might check that the mesh and the capsule have the right relationship (maybe the capsule is too low and the mesh is too high)
  • you might try hoisting the character up a few meters in the air, see what happens
  • also try turning on physics
  • check your collision settings
  • check your movement mode (it might be set to flying… I’m guessing your default land movement mode should be walking)

(Why can’t I write a comment rather than a answer…?)

Well the character’s capsule physics boolean is unchecked, the spawn transform is in the middle of the flat map (0X, 0Y, 0Z)

I don’t know what it is, I even removed all the blueprints inside my character and nothing changed… :frowning:

Sorry for the late response (being busy).

ALL checked ! Still fails to go on the ground !
Also, I tried to place the character directly into the level, it’s the only way it works !
When I place my character into the world without spawning it, he is not stuck !

Voyder Rozann

mmm… puzzling…

just one more question, if you place your character in the world… but hoist him/her up in the air… does he fall to the ground as intended?

Actually, yes ! It falls like normal… No stuck, with and without the blueprint inside the character…

…is it a player character, or another actor type?

It’s a player character, yes ! Not an actor like a bullet that can be fired, no !

sorry for all the questions… I think this is the issue… :slight_smile:

When the player character is spawned in the same way that normal actors are usually spawned, it isn’t ready to accept input. If you place it in the level, or spawn it using a Player Start, it will receive input and behave as expected.

Well, maybe I did explain myself badly but…
The player character is actually an “Enemy”, I will not and can not control it.
If I spawn (with the level blueprint) the “Enemy” a few meters above the ground, it’s not falling.
If I put the enemy in the level a few meters above the ground, it’s falling.
The only thing that works is the blueprint inside my character. The blueprint is executed normally !

… this one has me puzzled… try printing out the current movement mode of enemy character… what mode is it in while it’s hovering in the air after spawning?

Wow, really weird ! It’s saying “None” ! So… My “Enemy” doesn’t have movement enabled !

Oh wait, just checking on the character movement “Run Physics with No Controller” resolved the problem !
Well… I will post my answer then !

1 Like

sounds like the issue… so set your character’s default Land and Swimming movement mode in the character component… if this doesn’t work, you could use the character’s BP Begin Play to set it to walking or falling

If you ran into this problem, maybe that will resolve it.

In the character movement component, under “Character Movement (General Settings)”, expand the hidden area and check “Run Physics with No Controller” !

EDIT : A better way is, on the “Class Default” panel, under pawn, set “Auto Possess AI” to “Placed in world or spawned” !


Thanks for this answer. I was having a different issue but this helped me. I’m spawning an Actor (BP) to scene level, that has an AI controller. Since “Auto Possess AI” was only set to “Placed in world” (not spawned), it was not working, but when I manually put the BP in the scene, it worked. So after a lot of testing, “… or spawned” did the trick.

1 Like

Solved my problem. Thank you;