Spawned actor has no class in standalone

I’m dynamically spawning equipment for my AI army and have run into a problem. It seems that in the standalone version of the game there is no class associated with the spawned object. To debug this, I run the newly spawned item of class BaseItem (all items are of class base item) through a cast node to see if it casts to base item. As you can see fromm the warning at the bottom of the image, it is saying that it does not need the cast because BaseItem is a BaseItem.

When playing in the current viewport it returns just fine and outputs what you would expect. However, in standalone it fails the cast and outputs that it has no class. I’ve tried getting the class of the spawned object before the class (get Class->get display name) and it returns actor. I can store these spawned actors in an array of actors just fine and they stick around but I can never use them as anything other than actors.


For a bit more background, This is running on 4.8.3 (we are on a weekly update schedule right now so updating will take too long for the moment ) The objects being spawned work fine in other places within this same blueprint. (Player State derived class) and the structure that holds the class that is being spawned is used in multiple location as well. Unfortunately, I can’t repo it in a smaller project and it has never happened before so I was hoping to get some insight into what COULD be causing this kind of problem. Even a direction to look in would help at this point.

so typical for ue4- i wish I could help, but i am experiencing a similar bug which just does NOT work in standalone- i dont know why there is such a difference :confused: