Spawned Actor Blueprint Falls Through The Floor

I have an enemy character that when he is defeated, a piece of loot is spawned. The loot is an actor blueprint with a static mesh and a projectile movement component to shoot it in the air a bit and then land on the ground. All of this works except for the landing on the ground part. When the enemy character is destroyed, the loot actor is spawned and goes a little ways in the air and then falls directly through the floor. Is there a specific preset I need to have the collision settings on or is there another component I am missing.

Any guidance on the issue would be greatly appreciated.

The loot is an actor blueprint with a
static mesh

Could you show us the collision settings of this mesh?

Collision settings for the static mesh.

I have the same results with cubes and spheres within the engine. I opened the static mesh I am using and its collision default was set to BlockAll. Should that be Custom to match what the actor collision is?

There was no green wireframe around the mesh. I see the Collision button in the tool bar at the top of the viewport - should I use Simple or Complex Collision?

Looks fine to me. Are these the only objects that seem to ignore collision?
Consider adding just a static cube component (available in the engine) for testing purposes.

If you’re using a custom mesh for this, make sure it has collision in the first place:

The green wireframe after enabling CollisionDrawingOptions in the toolbar.

Static Mesh does have collision.

This only displays the collision, if you select Simple you do not see the green wireframe? Or, maybe it’s the floor that is the culprit?

It does show up - I didn’t have the box checked. I thought maybe the floor as well, but the First Person Projectile collided properly with the floor and walls. It’s gotta be something with the actor BP.