Spawn Decal At Location — Wrong Material?

G’day everyone,

I’m just wondering if anyone else has been having any issues regarding the “Spawn Decal At Location” function rendering the wrong material? Perhaps I’m doing something wrong (very likely). Does the material have to be classified as a “Deferred Decal” in the material properties? [Edit: Yes, it does! Decal is now working as intended!]

Any clarification will be greatly appreciated. Thanks!


G’day mate!

Good to see that it worked out for you :slight_smile:

By the way, keep in mind that currently decals have a problem with indirect lighting (due to the deferred rendering model), so if you notice that decals do not look right, try the following:

Change BaseEngine.ini and enter the following entries under [SystemSettings]


Then, use one of the DBuffer blend modes (a setting on the decal material).


Hi Michael,

Thank you for replying. I have noticed that the decals can render incorrectly (i.e. stretch or only render the normal map) depending on the angle/surface. Do I modify the main BaseEngine.ini (located in “C:\Program Files\Unreal Engine\4.1\Engine\Config”)?