Spawn Actor does not initialize AI

Using the SpawnActorByClass does not build and link an Actor’s AI. Instead, we must use SpawnAIByClass. This breaks generic spawning behavior, even though there is UI to select an Actor’s default AI class in the Blueprint editor. This is inconsistent and requires unnecessary work and consideration when building AI-driven Pawns.

Hey GrimlessBBS,

Take a look at the thread linked below:

I believe you’ll just need to set the Auto Possess AI option to Spawned instead of just Placed in World for this to work properly.

Let me know if that helps.

Have a great day

1 Like