Spacescape dds file invalid format

Hello, I’m pretty late in the game for using spacescape and I want to use it for a project. but I keep getting this error

Error: DDS file contains data in an unsupported format.
Error: Texture import failed

I tried exporting it in the unreal option and the source option, also tried going with 512 and the result is the same. I’m thinking maybe I don’t have something on or updated. perhaps a different method? Has someone got this error before? if so how did you resolved it? I tried looking into some of the documents posted on here about it but the pages and links lead me to a downed paged. I asked a couple peeps on youtube and they have no idea. well one of them didn’t know, the others haven’t replied yet. this is what I get every time I tried to import it.
Also, I’m working on a mac.

I’m having the same issue in 4.21

Did you ever find a solution for this?

Had the same problem.(with UE 4.23)

I think Unreal engine changed DDS format.and spacescape has not been updated yet.

you have to open the file in photoshop (or anything like who can open DDS file) and re-save in DDS (32bits/Channel, ARGB 32 bpp, unsigned) no mipmaps, and then you can import it to UE.
hope it works for you