space ship bluprint


I am new with un4 and i like the program and it is powerful and easy to use and learn i was working in the program for 1 week and i can do loot of thing but it hard to find turtial in this day :rolleyes:

I need help with space ship i saw in contact example that is there is space ship now when i open new level and play it it don’t start with the spaceship like i want it start with fps charcter now i tried and searched many time and nothing find can someone told me please how can i do that ??
also i tried with other open source project and the same problem i got

best regard

Open the launcher - create a new project - choose the flying template. Now you should see it. :slight_smile: -> I think currently you are using the 3rd person template (blue character)

thanks it work great :smiley:

i have anthor problem when i migrate the space ship to me project and change the the flying game mode blueprint to space blueprint, i start the project but i cant handle the mouse like there is no mouse blueprint it just go up and down and left and right is there sloution for that ?!

Do you want to have a combination between the flying template (up down left right) and the 3rd person template (look around with the camera)? What exactly do you mean with “space blueprint”? Check if the project inputs are like in the flying template :slight_smile:

I think you need to setup your inputs in Project Settings.

no i don’t i just want flying template , i mean with that the space ship blueprint
this what i did :

  1. i opened a new project flying template and migrate the BP_UFO_Physics from GDC2014( unreal engine contact )
  2. changing the flying game mode to fit the BP_UFO_Physics blueprint
  3. played the project and there was the shock :confused: i can play free with the spaceship but i can’t use the mouse i cant go foreword and turnaround

can u help :rolleyes:

Ah, know I know which UFO you mean ^^

  1. migrate it to the new project -> right click onto the ufo blueprint - migrate - choose new project folder
  2. open the new project (e.g the third person bp template)
  3. double click onto the gamemode (in the 3rd person bp -> mygame)
  4. under the properties add the ufo blueprint to “Default Pawn Class”

Now everything should work :slight_smile:

it work great thanks again and again