Space bar is acting like click with my UMG widget

First and foremost I would like to mention that none of my UMG widgets have ‘Is Focusable’ set to true, which is apparently what a number of people are having trouble with concerning this odd keyboard interaction.

For some reason the widget still seems to be picking up keyboard input and treating the space bar specifically as a click. Is there a way to disable the space bar altogether or fix this issue in another way?

I’m having the same issue. Did you ever find a solution to this?

On the button details, uncheck the “is focusable” option.

In a blueprint widget you can override the function On Preview Key Down and from the input In Key Event call Get Key and use the function Equal (Key) to compare it to the space bar. If true, then you can use the function Handled to create an Event Reply for the return node so it won’t do anything; otherwise, you can use the function Unhandled so it will be processed normally.

https://forums.unrealengine.com/development-discussion/blueprint-visual-scripting/42707-umg-how-to-disable-tab-and-keyboard-nav-keys