Source code/hairworks build

So I downloaded the .zip from, unzipped it with winrar, and ran setup.bat and then the GenerateProjectFiles.bat, I double-clicked UE4 in project files, In Visual Studio Community 2013 set solution configuration to Development_Editor, solution platform to x64 but when I build I get this:

1>------ Build started: Project: UE4, Configuration: Development_Editor x64 ------
1> The system cannot find the path specified.
1>C:\Program Files (x86)\MSBuild\Microsoft.Cpp\v4.0\V120\Microsoft.MakeFile.Targets(38,5): error MSB3073: The command “…..\Build\BatchFiles\Build.bat UE4Editor Win64 Development” exited with code 3.
========== Build: 0 succeeded, 1 failed, 0 up-to-date, 0 skipped ==========

Tell me what I’m doing wrong.

I here: [advice needed] hair solutions - Character & Animation - Epic Developer Community Forums that all you have to do is download the hairworks version of unreal and go through the setup the way you would the vanilla source code. Do I need to use a git shell or something?

Bump Please

Hey Maim Games-

I was able to successfully build the engine from the link in your first post without issue. Based on the error posted it seems that there may be an issue with where the editor files or VS is located on your machine. You may want to try unzipping to another location (the desktop for instance) and try running again. If you run into the same error again you may want to try reinstalling VS.


I tried extracting it to the desktop, reinstalling VS extracting it several places including the file where everything gets downloaded by the setup.bat- The setup .bat didn’t work there don’t know why; my best guess is that its parent folder is hidden. Whatever the case I think whatever caused the setup.bat failure is causing my troubles So is there a way to specify where the setup.bat downloads everything?

Just so we’re clear- There’s NO WAY to make the setup.bat download to a different location?

There is no way to change where Setup.bat downloads files to. It searches for and reads info from files in specific locations based on its default location and then installs the dependencies to the appropriate places for the engine to use. If the folder where the engine was unzipped to is marked as hidden then it may help to make the folder visible. Also, if you’re using VS2013 you may want to try upgrading to VS2015 to see if that helps.

I got it working by extracting it to where the setup.bat didn’t work and running it a few times. That’s too bad that you can’t change the download location, the C: drive’s gettin a bit tight, but as long as I can save my projects elsewhere I should be alright. Thank you.