Source Code Build Fail - MSB3073

Hello all, While trying to build the source code version of UE4 (The Microsoft ATG Version, which according to Engine\Source\Runtime\Launch\Resources\Version.h is 4.13.1)

i get a build error (see log attached)
link text

Things i have tried

Re-download of zip
Reclone Via GITHUB
Tried on two different Hardrives
VS2015 Is being run in admin mode

i shall try the pure version of UE4, And update the post

EDIT: Pure UE4 Also failed, Log bellow.
also instaler version of UE4 Works fine
pure error

Hi Mulldoon,

From the log you provided for the ATG version of UE4, it looks like the Windows 8.1 SDK is missing a file (nldef.h). Could you try reinstalling the 8.1 SDK to see if that helps?

The log for the UE4 source code build that you provided does not indicate what the actual problem is (The MSB3073 error message just indicates that something failed, but does not specify what failed). I was not able to reproduce any build failures in the release branch. What branch or tag did you download from our repo?

just an update,
visual studio broke so im having to reinstall that, but luckily that includes the necessary SDKS will update once finished

and it was the release branch at the time of writing the post,

Hello, for the pure version of UE4 Updating/Reinstalling Visual studio worked

due to the ATG Version seeming to be needing the Win10 SDK i have had to use a W10 virtual machine and installing everything to that and that has seemed to work

Hi Mulldoon,

I am glad to hear that it appears to be working for you now. Just to make sure that you are aware, it should be possible to install the Windows 10 SDK on other versions of Windows. I have the Windows 10 kit installed and I am using .