Sound Source Bus - Can't seem to get it to play a sound.

Hey there.

Just found the sound source bus class and thought it would be a great thing to test out for routing some audio around. Unfortunately, I can’t get it to work.

Here are the steps I took:

  • added an ambient sound with a soundcue attached into the level
  • created the bus asset
  • threw it into the level
  • applied the same attenuation asset to both the sound source bus and the original ambient sound (also tried it without one)
  • selected my desired soundcue and added the sound source bus i created to its “Pre-Effect Bus Send” (also tried it on the Post send)
  • turned the Send Level up to 1
  • started the game

and I only hear the audio from the original ambient sound. I’m just wondering if I’m missing a step, thinking about this wrong, or if something else in my project might be interfering with this bus.

I’m using 4.19 preview 3 and have the audiomixer enabled.


Hey Mitchell,

I just synced up latest 4.19 here and pretty sure Source Buses are working as expected.

One thing to use to help better debug is to mute the audio of the original sound so it only ever outputs source bus audio (this basically bypasses sending audio to the default submix).

But yeah, my steps were similar to yours.

I decided to test with a synth here (running my SynthSamplePlayer object) and discovered that I hadn’t allowed routing synths to source buses… so I after fixing that (latest 4.19 on github will have that fix), I was able to get it running pretty easily.

  1. Make sure the source bus is set as the pre-effect bus send (could be post-effect too… the difference here is pre and post source-effect chains, which can be a useful distinction) to your source bus. You can see this in my picture in my previous comment where I send the source audio to TestSourceBus.

  2. Then make sure the source bus is playing in the level like a normal sound (e.g. ambient actor).

Hi Obsidiaguy!

So the workflow is:

Create a SourceBus Asset
Add the SourceBus to your SourceBus Send on your Source (SoundBase and soon (added today) SynthComponent)

Pre-Effect Bus Send means the audio will be sent before the SourceEffect Chain AND before the Attenuation/Spatialization stage
Post-Effect Bus Send means the audio will be sent after the Source Effect Chain and Attenuation/Spatialization stage

If you want to hear your SourceBus outside the Attenuation Radius of your Source sound, you will need to make sure that Virtualize When Silent is turned on.

Add your SourceBus and your Source to your scene.

SourceBuses can also send to other SourceBuses for amazing and wacky routing effects!

Let me know if you run into any issues.

EDIT: Aaron beat me to it!

Thanks guys.

I did manage to get it to work. It seemed to only work when I would set it up, then save and restart the editor.

I tried it on a new empty project and it wasn’t working. I thought, oh maybe I need the Sound Utilities or the Synthesis plugins enabled, so I enabled those and restarted and it started working.

So I went back to my other project that I never saved after attempting the sound source bus, checked the plugins and saw that I already had the Synthesis and Sound Utilities plugins enabled, so figured it probably wasn’t that. I set up the sound source bus and it wasn’t working there, either. So i saved it and just reloaded the project and it was working fine.

Not sure why it’s doing that for me, but at least it’s working.

Thanks again.

Weird. I’ll look more closely at them – I was able to use them without restarting. I don’t think there’s anything that would require a restart.