Download

Sound Quality Automatically Reduced On Import

Hey guys,

I noticed that when playing sounds in the editor, the sound quality seems to be automatically reduced. This has nothing to do with compression quality on the Sound Wave. The high end is lost when playing sounds in the engine. Sounds like a sample rate reduction.

I’ve noticed this in both the new audio engine and the old, and have tested this from 4.16 to 4.19.2. To repro:

  1. Create a new project using the first person template on 4.19.2
  2. Launch the project, and navigate to Audio/FirstPersonTemplateWeaponFire02
  3. Play the sound in the editor, and then play the sound in the game. After doing this, right click on the “FirstPersonTemplateWeaponFire02” sound wave, and choose Asset Actions-Export
  4. Now, you’ll have that sound outside the editor. Listen to the sound played outside the editor, and then within the editor. There is a noticeable loss of quality. You can also record the output of the game, and A-B between the recorded output and the original sound in your DAW. It is very noticeable this way.

I don’t know if this is a bug or some memory saving feature, but I would like to have the sounds within the editor sound exactly the same as they sound in my DAW. Is there a way to do this?

Thanks,
Kevin

Yup. Noticed it as well. Everything seems to sound more flat. What is up with this?

mostly Daws work with wav 32/64 bits ( no dithering audio ) . that’s why often the sounds seems more accurate / clearely on our DAW .
keep in mind even you play a sounds 44. khz 16 bits on your daw , your daw for playplack streaming do a copy on 32 bits or 64 bits . On UE4 engine , the audio files played as the original sample rate .

This is not just in DAW. You can play the file in VLC. There is a noticeable difference between the wav files in the engine, and the wavs outside the engine. If you follow my repro steps, it clearly shows that difference.

Keep in mind that the repro steps use a sound within Epic’s first person template. Anyone can test this out and hear the issue.

There’s currently no way to play uncompressed audio playback in UE4 – on Windows, for example, it’s cooking to Ogg-vorbis and then playing back the compressed version (as you would hear it in the game). I’d like to allow content-browser playback/preview play the raw uncompressed audio vs the compressed version, or at least have that as an option in the editor.

We have a huge list of things we want to improve around asset management, asset workflow, asset import/export, and customization of per-platform compression.

Thanks for the info, but I’m not sure if it is solely compression issue. If you take that same file from my import steps, and import it into Wwise to apply compression there, you can get the file to be smaller than you could in UE, and it still sounds like the file being played in VLC.

This is not an audiophile post, where someone is complaining about something that can’t be heard by 99.9 % of the population. I’ve shown this issue to people who know nothing about audio, and they can easily spot the high end being rolled off.

It would be good to have someone look at this issue, because it may be some setting where UE is doing something weird under the hood.

Got another guy complaining about this issue. If there is a huge list of things you guys want to do, then can this problem be prioritized?

https://forums.unrealengine.com/deve…eal-sound-loss

Yeah I’m starting to get a bit suspicious about what Unreal is doing to audio assets under the hood. Would importing much higher fidelity originals help at all with this issue? I’ve traditionally imported sounds as 44100 mono WAVs but maybe it’s worth upping that if it’ll help combat this. Tried importing some thunder recently that sounded fine when played in any external media program but in-game became a horribly muddled mess even with a compression quality of 100.

The linked post above describes this issue and a potential fix! The problem that I’ve been running into is that switching to AudioMixerXAudio2 on 4.18.3 doesn’t seem to actually switch it. However, switching to AudioMixerXAudio2 on 4.19.2 does. The directions are posted here:

https://forums.unrealengine.com/deve…ck-start-guide

I’m not sure why this is yet.

After updating my older project to 4.19.2 and confirming that AudioMixerXAudio2 is activated, the problem is gone. It’s weird because I went through these steps before on a new 4.19.2 UE project, and didn’t see the mixer activate in the output log. Only after uninstalling the engine, and doing everything from scratch did it work. Maybe I missed a step the first time. Those directions are linked in my post above. The way I was ale to see that the mixer was activated is that it gave me additional info in the output log such as:

LogAudioMixer: Display: Audio Device Output Speaker Info:
LogAudioMixer: Display: Name: Focusrite USB (Focusrite USB Audio)
LogAudioMixer: Display: Is Default: Yes
LogAudioMixer: Display: Sample Rate: 96000
LogAudioMixer: Display: Channel Count: 2 (was Mono? No)
LogAudioMixer: Display: Channel Order:
LogAudioMixer: Display: 0: FrontLeft
LogAudioMixer: Display: 1: FrontRight

This info does not show up for me if AudioMixerXAudio2 is not activated.

The only difference now is compression you may hear from .wav becoming .ogg, but that difference is negligible. The big thing is to just make sure that the AudioMixerXAudio2 is working.

I did some tests with white and pink noise a few days ago, after noticing the same issue. I’m still running into this problem on 4.19.2 with audiomixer activated. There’s a hearable roll-off on the higher end of the spectrum, even at the highest quality settings. No roll-off when compressing to ogg Vorbis or ogg Opus with Reaper for example.

FWIW, I tried playing back the same sample in Wwise and got a similar result to Unreal when using ogg at max quality.

I ran into the same issue with the higher end of the spectrum getting bad quality.

But importing with sample rate 48000 fixed it. I’m using the new audio engine.

Hey! I’ve followed both advices on how to handle the problem (activating AudioMixer and importing 48kHz file), but now I’ve got another one- I lost the low range, while in Wwise I’m not having any of these issues. Any idea what might be going on?

What version are you on? Is this playing back attenuated/spatialized? Do you have Air Absorption on?

resurrecting this thread because I am having the same issue.

Is there any clear explanation / documentation as to what UE4 is doing on import? I am using the new audio engine with 48khz source wavs and whenever I import sounds my low frequencies turn to junk and disappear. I’m talking 200Hz-ish and below. What is going on? I’m not using any 3D settings / air absorption etc etc, just trying to play a 2D sound. Can you tell me exactly what compression is being applied? It also seems strange to me that the audible difference between compression quality 1 and 100 is really not that big.

I’m currently using UE4.20.3

Any help / info appreciated @dan.reynolds .

When you audition a sound in UE4, you are hearing the compressed asset version (as in true to run-time, or like an in-game preview). By default, the Compression Quality for a new asset is 40/100, if you need to raise that, then raise that value in the SoundWave details panel.

Resurrecting this because I had the same issue, but solved it.
The audio HAS to be converted into a 16bit format, or it will not sound right in UE4. If you import a file that was exported as 32, it will sound distorted.
I used Sony Vegas to export my file into a 48000 16 bit Stereo PCM and it sounds perfect now.

Unfortunately, even in 48kHz format, you get a distorted file. The upper frequencies in 48kHz format are cut less than if you add a file in the 44.1kHz format. But then lower frequencies are beginning to be reduced. For mobile small projects, this is probably not essential. But for serious projects - this is unacceptable.

To reproduce - just add whiteNoise wav file in different formats to UE and check how it sounds with any Freq Analyser.

Hello, has anyone came up with solution to this? I am loosing everything bellow 200Hz both on 44,1 kHz and 48kHz, 16bit. Also around 5dB of gain which you can see from the pics below.

I hear ya @esadreb

This is frustrating because this thread / issue has been around for ages. I am experiencing exactly the same as you. I have even removed the -3dB attenuation that UE4 applies by default for headroom purposes (set in the Windows config file if you are on PC). I’m seeing a loss of -6.3dB on tests that I am running whereby I am playing a 2D sound from UE4 and comparing it to the level of the source.

More worrying is the loss of bottom end. You are right, under 200Hz it starts to fall away considerably. I haven’t been using UE4 audio for long enough to know if this has always been the case but it has been an issue for at least the last year. It’s a pretty serious problem as far as I’m concerned.

This has nothing to do with 3D sound settings, air absorption, Soundclass settings, compression settings. I have been running tests simply by playing back a 2D sound in both the content browser and in a packaged game.

I am using the new audio engine and 48khz source assets.

Hopefully this will get fixed soon. In the mean time I will log these issues on UDN.

Cheers.