Sound not fading out

Hello, I have two audio components in my BP and the following Blueprint nodes when the player chooses ta start a fight in my Xenoblade-like RPG. But the music doesn’t fade out so the fight music can fade in, they’re both playing simultaneously . What am I doing wrong?


How are you creating the sound? The fade node doesn’t work with all types…

That looks okay, but you’ll need to show us more information. How are you creating Music and Fight Music? Are they sounds or sound cues? (They should be the latter). Most importantly, are they set up as Audio components, and of what actor? (Probably your character).

They are both Audio Components on the character yes. Also, they are both Sound Cues. When I stop the fight music through the enemy (when it dies) it works but the normal music doesn’t wanna go away even with the Stop function.

I just set the Sound Cue in the Audio Component in the Blueprint Editor.

Hi, I don’t know what the exact ‘rules’ are, but I know that when I tried something like this, an audio component that I had preconfigured in the details panel worked fine with play, followed by fade out. But when I spawned a sound it did not.

From what you typed above, it sounds like my first option here. Did you start the sound with the Play node?..

yeah I start it with a play node at the beginning of play. You think I should change that somehow?

No. Weird, that worked for me. Just to check:

  1. Manually made an audio component in the BP
  2. Set the sound in the details panel
  3. Started the sound with a Play node

Then the fade out worked…

Yeah exact same procedure. I guess it’s the Lubuntu version that has bugs. :frowning:

Features… yup. I certainly found that with audio and attenuation, different things are possible depending upon how you start / stop / specify sounds etc…

Spawning didn’t work with fade for me, maybe it does for you…