Sound moving with mesh


So i’m making an airport map, and i want an airplane to flyby. So i created a blueprint class with an airplane and a projectile movement component. Now i want to add a sound to the plane which moves with the plane, so when the plane flies by you hear the sound and when it’s far away you don’t, and you also hear it approaching etc.
I tried a few things with changing the location of the sound, but you hear it everywhere in the map at the same volume all the time. Can anybody help me? Thanks!

I’m not sure why the 3D part isn’t working with that node. I use PlaySoundAtLocation for my weapon firing effects and it works as you would expect.

I can say that for an actor that produces sound continuously, you probably want to use the SpawnSoundAttached node so the sound moves with the actor.

Add an audio component to your plane. Convert your sound to a sound cue. Take a look at the images.




Inside sound cue:


It might require some tweaking but this should get you going

Hey, so thanks for your answer. I tried this but couldnt find the “moving sound” component?

I just called my one “MovingSound” :slight_smile: As I said at the start of my post it is an Audio Component. You will find it in the add component list.

I’ma try this out tonight. Thanks already!

Did this work for anyone? As I understand if the “play” function causes the audio to play right away, as soon as you start the game. I’m also trying to get a sound to attach to and move with a plane, but the plane visibility and movement is triggered later in the game so I need the audio to start with the plane. It does play again when I trigger the plane, but it does not move with the plane (change volume, pan direction, etc.)

Hello, did you find a solution for your case? I also try to play a sound at certain time, not when the game starts. And I want to move my sound with the object.

Having the same issue as well! :frowning:

Whats the issue you are having exactly, i’m sure with some info we can work this out :grinning:

The issue I was having, is that “play sound at location” doesn’t update the location repeatedly, which I suppose makes sense, as it’s not running on tick (I was triggered the audio with a custom event). Therefore, the sound was coming from the original position of my car, and wasn’t moving with it.

I managed to fix it by adding an “audio” component ti the car blueprint and then using “Play” instead of “Play sound at location”, so that the audio component, linked to the car, would play the sound, no matter where it is.

Thanks for offering your help though!

Cool, yes that’s the exact way to do it. Glad you got it working.

To avoid the sound playing as soon as you start the game, just uncheck the “Auto Activate” thing in “Activation” at the bottom of the detail panel ^^