Sound Mixer node stops sounds with 0 volume

For creating dynamic music / sound mixing, we would like to smoothly go between tracks aligned at the same time.

You can set the time of a cue at playback so that could work but I can’t read where the current track is at to sync and crossfade them.

The only option seems to be the sound mixer. I can add several tracks with one having volume up then change the volume dynamically to make interactive music. Problem is the sounds stop playback at 0 volume. I realize this is a performance issue, but it should have an option to sync the playback time or play silently at a cost if you need it.

The only workable solution I could find is to set the playback of the other tracks really low (0.01 or so) in order to keep them in sync.

Seems like there should be a legit way to do this.

Have the exact same concern. Putting the volume at 0 should not equate stopping the audio altogether unless chosen to.

as of 07/02/17 i am still getting this, is this a bug? any news on fixing it?

I’m having the same problem. Does anyone know if there’s a better way of doing this, other than setting the volume to 0.001 instead of 0?

Has this ever been looked at? I’ve been asking about it for a while. Is there a suitable workaround?

I think I have found it. It’s a checkbox that says “Virtualize Sound When Silent” on the specific sound you want to maintain playing. It may also need to be activated in project settings.

1 Like

That fixed it for me, thank you!

Worked for me as well. Although it is not the most ideal solution as you have to make the change in each WAV asset you want this applied to. It seems like this should go in a concurrency asset that could be shared across multiple sounds.

(V.1.8) - From the “testing” I’v been doing, putting the volume at 0 makes make the audio component “Invalid”(you can test this with the “Is Valid” node), basically unusable. It seems equivalent to the “DestroyAudioComponent” node, which also makes the audiocomponent “Invalid”. The volume shouldn’t have anything to do with making the audiocomponent “Invalid”. I hope the team fixes this.

Thank you. ive been haveing this little crackle everytime a sound fades in and out because fade out keeps destroying the sound at volume 0 causing a tiny crackle in the sound when it begins or ends.

Select all your assets, right click → Asset Actions → Bulk Edit

worked for me, on 4.22 its called “play when silent”.