Sound issues 4.14

I play sound at location for a spell. The sound ran fine but I didn’t like it so I created a new sound. Imported that sound changed it and re-complied the bp. The first sound played. I deleted it. The first sound played. I deleted both of them took out the node and tried to import the second sound. The first sound played even though it shouldn’t exist in the project.

Looked at the asset references no mention of the first sound. Tried it again to drag and drop import the second sound, still the first sound played. Tried to import it through the content browser still the first sound played. RAGED BEYOND BELIEF… and decided that maybe unreal engine is not production ready seeing as how it changes SO drastically I have just wasted three years of my life and about 5 grand…

THANKS first engine ever that made me rage quit.

Hey Drixil,

If you can reproduce the issue and give me the steps to do so, I would be glad to assist you. I attempted the steps you provided and did not get the same results.

Our audio engineer did a big release stream on the new Audio Engine coming to Unreal which is going to be a really great improvement. Sorry to hear you are having troubles, but I wouldn’t let something like this stop you from using the engine. Plenty of developers encounter hiccups like this, but if they gave up, you wouldn’t have the games you play now.

Unreal Audio Engine Twitch Release

Try to keep a calm and understand what/why something could be happening, and if you cannot find the solution, work around the issue. This is game development in a nutshell, and nothing is expected to run perfectly during the development cycle of any game. That is why it is sometimes best to have some coding knowledge as well as it can help with the really granular issues that you cannot seem to find a solution.


I think I lost it because I had actually deleted the sound and there was absolutely no reason for it to be playing. The final snap happened when it began playing the second sound and then blended into the first. My mind says “computer’s are logical, they only do what I tell them to do and nothing more”. In this case it was insisting on something that didn’t exist.

This bizarre error has no reason to happen. I even went back after rebooting my machine and it was still playing the first wav even though it didn’t exist in the project. I was wondering if it had something to do with that new map build data Anyway I take my development very seriously and I am working on this game alone so ya…

Maybe it has something to do with caching or something?

Ok so I found a work around though it doesn’t eliminate to weird bug I found. I was placing the sound in a character skill component. So I just removed the function all together and placed it on the character. This cleared out the issue though it is kind of the wrong way to go about it.