Sound is Broken in 4.12 to 4.14. Update: Sound Mixes are broken but found a work around

I’ve been tackling this bug ever since updating to 4.12 to 4.14. I am having issues with new sounds not playing after the number of total sounds reaches 30 inside stat sounds. After it reaches over 30 I pause the game, and within the pause menu I have dialog that plays about 40% of the time. I have the ability to spam it (As it is a lengthy dialog of a note playing) and it doesn’t play every time. I have messed with the concurrency and set default up to allow 300 sounds to play but it still doesn’t work properly. Within stat sound it shows that it is playing and has a volume. But no sound comes out.

I had recently updated from 4.10 to 4.12, 4.13, and now 4.14. If that matters.

I’ve attached a picture as proof that it is playing inside stat sounds but there is no audible sound. The nightmare sound is the one that is supposed to be audible but isn’t

Any help would be greatly appreciated.

Edit: Talking to my team I believe this issue started with 4.12. We went from 4.10 to 4.14 in a week because of these random audio bugs. It seemed better in 4.14 until we went into areas of high number of sounds playing at one time.

It feels like what I’m describing is a bit different then the other sound issues I’ve seen posted about 4.14. Has anyone else been able to repro these steps? Usually involves spamming sounds, and finding the one that isnt playing.

Eureka! Ok this may sound weird but I solved it, and may help everyone else.

I’ve been using a SoundClass with a SoundMix that adjusts a sound classes to 0. Now if the SoundClass you are mixing is set to 0, and playing in the world, there is a chance that the sound you are trying to play, will not play (meaning it will play but not audible). I fixed this issue by setting the sound that was 0, to 0.1 and it worked, my repro case which had 100% chance to break now worked everytime. I then attempted to adjust the volume of another class that was playing to 0, and the bug occured again. I then set it back to 0.1 and attempted a sound class that was not playing. The bug did not occur. I believe the break is in the SoundMix and has been occurring for awhile.

This is due to switching back to older behavior where if a sound is at zero volume, it’s not played at all. There was a few releases where we allowed zero-volume playback for all sounds but it turned out to be extremely expensive for real-time decoded sounds. We flipped back to defaulting to the old behavior (which was 4.9 and earlier). If you want specific sounds to always keep playing even if at zero volume, you need to enable virtual sound playback (in audio settings) and then enable it on the sound itself (Virtualize When Silent). It’s called “virtualize” even though it’s technically not a virtual sound – eventually we’ll switch this to being a true virtual voice. This was mentioned in a release note but hadn’t been communicated clearly enough.

Minus_Kelvin yours is not a accurate the fix for this issue unfortunately. I had already tried virtualize and did not work. The sound in question is playing at 1.30 volume but is not audible. As per the picture it shows that the volume should be at 1.30 but is not audible. The issue is with the Sound Mix. As described in my resolution of how to fix the issue it has to do with the other classes, when set to 0, will randomly break the dominate sound mix if many of the volume 0 sound classes are being played.

This is strictly a bug do to the SoundMix and how it deals with SoundClasses. I have tested it top and bottom. This has been happening since 4.12 (we skipped 4.11) Even if this seems similar to other issues this has not been brought up as accurately as I am stating, and has not been fixed since 4.12.

Edit: Looks like the picture doesn’t show the exact sound (my bad). But during testing it does show up as volume 1.30 and is not audible.