Sound 'Ghosts' Playing after Level Load

We’ve found a weird case in our project where playing certain sounds at some point prior to a level transition causes a weird audio glitch after the level transition is complete. It doesn’t seem to matter how the sounds play (it can be a result of ‘Auto Activate’ on a component, or explicitly playing that component, or even using PlaySound2D without an audio component), nor how long prior to Open Level the sound has played (in this case, many seconds).

We identified the specific sound cues by verifying that setting their Sound Class Volume or their Volume Multiplier to zero makes the glitch go away, but the glitch itself sounds nothing like the sounds (in this case, it kind of sounds like a piano key). We tried dynamically zeroing out the Volume or Volume Multiplier prior to calling Open Level, but that didn’t have any effect.

We also tried calling StopAllSounds immediately prior to Open Level, but not only was the sound in question not listed in FAudioDevice’s ActiveSounds, but nothing was being added to ActiveSounds between then and the glitch occurring.

The last random thing we tried was forcing garbage collection and waiting a frame, but that didn’t work either. Our next thinking is to try looking at the audio mixer, and see if there’s some kind of buffer flush that we can try, but none of us are familiar with that chunk of engine code.

Any idea what might be going on?

Interesting, the problem goes away when the following is added to DefaultEngine.ini:

That’s probably not something we want to leave on for the shipping build, though.