Download

Sound doesn't work in editor

My sound works in the packaged game but nothing plays in editor. Even when I try to preview a sound in the content browser, when I click the play button nothing happens.

I am using version 4.21 on Windows and even when I check the Windows volume mixer Unreal Engine does not show up in the list with the other apps I have open.

I have made sure Real Time Audio is turned all the way up in settings and have enabled Real Time in the viewport.

Any help would be greatly appreciated!

Hi @NathanVMP, sorry you’re having trouble. Unfortunately, I was not able to reproduce your issue. Do you have any more information that would be helpful to sussing out what is happening?

I find it super weird that an app running on Windows would not show up in the Windows Volume Mixer.

I found it very weird that UE4 wasn’t showing in the volume mixer as well, I’ve been stuck on this for a long time and it has even effected multiple engine versions.

I finally found the solution posted by gigahest here: https://answers.unrealengine.com/que…ml?sort=oldest

Just open the WindowsEngine file in Program Files/ Epic Games / UE_4.21/Engine/Config/Windows folder and just commenting (disabling) AudioDeviceModuleName=Xaudio2, and Uncomment (enabling) the AudioDeviceModuleName=AudioMixerXaudio2

And that worked for you?

Yes that solved my issue.

Same thing happend to me. But i did solve in a diferent way:

  • open your project game, then go to “Edit”, and click in" Editor Preferences"
  • they will open a windows. In the search bar, write “sound” and you will find two check box: “Enable Editor Sounds” and “Enable Game Sound”. check both

This solution hasn’t worked for me. Is it possible to specify the sound card in Unreal? i want to use ASIO and my MAudio Interface but no audio is working.

None of the above solutions fixed it for me. The only difference I have found between projects that have working sound and mine is bellow image.

UE_grey_normal_uasset.png

And I just cannot figure what the colour codes mean. If anyone has any pointers, I would appreciate it.

To follow up to this problem. I did not found any fixes for this error, but a simple workaround. I cloned my project in Library of Epic Launcher, generated Visual Studio project files and copied ‘DefaultInput.ini’ file from original project as a way of importing my set inputs. Now sound works in editor, and I don’t have any other problems while further developing my game as of right now.

Hope this will help someone, and I give up on finding what actually broke my project.